Closed Bug 426692 Opened 15 years ago Closed 15 years ago

jsdIScript.functionSource NS_ERROR_FAILURE

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 427164

People

(Reporter: johnjbarton, Unassigned)

Details

This statement 
 var src = frame.script.isValid ? frame.script.functionSource : "<invalid script>";

fails with
Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [jsdIScript.functionSource];

So first, Thank You! for an error message that points to the right line and even includes the problem field.

But what to do? Put a try block around every field access because it might fail?

Can't you return "null" or ""? That it failed isn't interesting if I can't do anything about it.
Basically a duplicate of bug 427164 which is better.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427164
You need to log in before you can comment on or make changes to this bug.