FF3 does not reload page content on startup

RESOLVED INVALID

Status

()

Core
Document Navigation
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Dmitry Kirillov, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

FF3 does not actually refreshes a content of the webpage after a startup (although it displays a 'refreshing' icon on the tab). 

Reproducible: Always

Steps to Reproduce:
1. Start firefox
2. Navigate to a page which content changes over time 
3. Close firefox
4. Wait until page content changes (by checking in some other tool)
5. Start firefox
6. Observe that a 'refresh' icon is displayed on the tab, but a content of the page in firefox is not updated
7. Press Ctrl+R. Observe that a content of the page is now actual.
Actual Results:  
Content of the page is not refreshed after startup

Expected Results:  
Content of the page should be refreshed.

Comment 1

10 years ago
If the data is cached and the HTTP headers say that it hasn't expired then Firefox will load from cache.  You can set Firefox to clear the cache on close using Tools>Options>Privacy>Always clear my private data when I close Firefox
(Reporter)

Comment 2

10 years ago
I checked on my http proxy - Firefox does not seem to get http headers to check if it was modified or not. 
HTTP headers from the site do not seem to have any expiry information.
Clear the disk cache and create a http log : 
http://www.mozilla.org/projects/netlib/http/http-debugging.html
(Reporter)

Comment 4

10 years ago
Created attachment 313349 [details]
http log files with cleared and present cache
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
There's no problem with a cleared cache - not finding page in cache, FF gets it from the server.
the problem occurs when the page IS in cache, but was updated on a server.

In my opinion the proper would be to check if the page was updated on a server.
In comment4 there are two log files inside the zip. Logs are created with -save-mode switch set to avoid possible trash from plugins.

The nspr_log_cache_NOT_cleared.txt contains lines:
0[333140]: Have status line [version=10 status=200 statusText=OK]
0[333140]: ParseContentType [type=text/html; charset=utf-8]
0[333140]: VALIDATE_NEVER set
0[333140]: NOT validating based on VALIDATE_NEVER load flag
0[333140]: CheckCache [this=26752b0 doValidation=0]

It results in a page not beeing reloaded although it was changed on the server.
I requested the log with cleared cache to get the original headers of the page.
VALIDATE_NEVER set looks like your cache settings are wrong.
is browser.cache.check_doc_frequency in about:config set to 3 ?
(Reporter)

Comment 7

10 years ago
Yes, browser.cache.check_doc_frequency;3
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → Trunk
(Reporter)

Comment 8

10 years ago
For me it does not seem to be a cache/protocol issue.

For some reason, FF loads the page with a LoadType = LOAD_HISTORY. After that in nsDocShell::DoChannelLoad there's loadFlags |= nsIRequest::VALIDATE_NEVER in case of LoadType == LOAD_HISTORY.
I'm not sure, though, what LOAD_HISTORY is intended to mean :-(. 
-> docshell I guess

LOAD_HISTORY is normally used when clicking the back or forward button. I don't know why it's set here though.
Component: Networking: HTTP → Embedding: Docshell
QA Contact: networking.http → docshell
Is this session restore loading the page?  Session restore on purpose loads exactly what you saw when you quit the browser.  That's the whole point.

Sounds to me like this is invalid.
(Reporter)

Comment 11

10 years ago
Yes, it is session restore. 
It probably makes sense that when you close and reopen a browser, you see exactly what you saw before. However, that was different in FF2 - it was actually reloading the page.

The thing that might have mislead me is that when you have several tabs open, when you close and reopen browser window, all tabs have a "Throbbler" icon, which usually indicates refresh/network activity. If there's no refresh at all, the icon probably should not be displayed. 

The throbber shows any time there's a pending load, which in this case there is.  Whether the load is satisfied from cache or not is immaterial.

Note that the images on the page, say, may not end up coming from cache.

In any case, there's certainly no core bug here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.