Style nsIAlertsService alerts on Vista

VERIFIED DUPLICATE of bug 426713

Status

()

Firefox
Theme
VERIFIED DUPLICATE of bug 426713
10 years ago
10 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

({polish})

Trunk
x86
Windows Vista
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-visual][polish-high-visibility])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
We should do some css tweaks to improve the appearance of system tray notifications on Vista to make them appear more native.  Probably giving them a tooltip background, and curved corners to match other system tray notifications will help.
(Reporter)

Updated

10 years ago
Blocks: 405605
Created attachment 314519 [details]
type of tooltip we want to emulate on vista
(Reporter)

Comment 2

10 years ago
Quick spec from the screen shot

-4 pixel corner radius (might get this from tooltip for free)
-tooltip background
-title 16 point with a color of (4,54,155) [only if default theme, based on bug 426660]
To avoid hard coding colours, why don't we:

 - make the titles of these notifications carry non-underlined link appearance
 - ensure that the entire tray notification is a link target
 - use system drawn grey colour for secondary text

So
.-------------------------------------------------, 4px corner radius
| ICON   _Downloads Complete_                     | 16pt, no underline, link
| ICON                                            | 
| ICON   All files have finished downloading      | 10pt, greyText
'-------------------------------------------------'
Forgot to mention, hopefully bug 426732 will make it such that we can get the right link colour for Vista from the system - it's not precisely the same as (4,54,155) but it's close enough for government^H^H^H^H^Hmozilla work.

Comment 5

10 years ago
(In reply to comment #1)
> Created an attachment (id=314519) [details]
> type of tooltip we want to emulate on vista

This is a systray notification, right? We don't actually have such notifications.

(In reply to comment #2)
> -4 pixel corner radius (might get this from tooltip for free)
> -tooltip background

Tooltips aren't interactive.
Summary: Style system tray notifications on Vista → Style nsIAlertsService alerts on Vista
(Reporter)

Comment 6

10 years ago
>Tooltips aren't interactive.

On vista the tooltip appearance is used for system tray speech bubbles (http://people.mozilla.com/~faaborg/files/granParadisoUI/contextulDialogStyleVista_i1.png).  This is what we want to base the overall style on, and these are interactive.

Comment 7

10 years ago
So, to sum this up, the "check your firewall status" is a systray notification (tip pointing to the icon), which we don't exactly have, although it's semantically close. I would consider tooltips (non-interactive) and contextual panels (e.g. the identity popup, appears on demand) completely unrelated; mixing theses things might lead to confusing interfaces.
(Reporter)

Comment 8

10 years ago
>might lead to confusing interfaces.

When Windows 7 enters public beta we will have six months to a year to make sure we aren't doing anything totally wrong.

Comment 9

10 years ago
I'm saying this because I think it might lead to confusing UIs right now.
(Reporter)

Comment 10

10 years ago
Why? The two background gradients are exactly the same
Because it seems like it could confuse the user about how the popup behaves and what he's expected to do with it. The fact that systray notifications and tooltips share the same background (on XP too) is probably less of an issue as long as they are differentiable. But that doesn't mean that we could use that everywhere. For example, a yellow background for identity popup (and probably for the alerts that we're talking about too) would feel very strange to me as an XP user.

(In reply to comment #7)
> the "check your firewall status" is a systray notification
> (tip pointing to the icon), which we don't exactly have, although it's
> semantically close.

I think another significant difference here is that our alerts disappear much
faster. Do the systray notifications disappear at all, or only by clicking them
away?
(Reporter)

Comment 12

10 years ago
>I think another significant difference here is that our alerts disappear much
>faster. 

They do seem kind of fast, I wonder if we should slow them down.  Also, does anyone know the full set of notifications that get passed to these things?

Comment 13

10 years ago
(In reply to comment #12)
> Also, does anyone know the full set of notifications that get passed to 
> these things?

// arguments[0] --> the image src url
// arguments[1] --> the alert title
// arguments[2] --> the alert text
// arguments[3] --> is the text clickable? 
// arguments[4] --> the alert cookie to be passed back to the listener
// arguments[5] --> the alert origin reported by the look and feel
// arguments[6] --> an optional callback listener (nsIObserver)

As far as them being fast, they're a little faster than normal ones (3000ms), but not too fast. Instead of slowing them down though I think we should make them mouse-sticky like XP notifications. We would probably want to add a close button too if we do that, because the user will then want the instant-dismiss ability.

See my comments in Bug 426713 Comment #10 about rounded corners.
(Reporter)

Updated

10 years ago
Keywords: polish
Whiteboard: [polish-easy]
(Reporter)

Comment 14

10 years ago
this bug is eligible for bug 462081
Whiteboard: [polish-easy] → [polish-easy][polish-visual]
(Reporter)

Updated

10 years ago
Whiteboard: [polish-easy][polish-visual] → [polish-easy][polish-visual][polish-high-visibility]
The work in 426713 is basically going to enable this, it should be marked as blocking this bug. (only mentioning after working a little on this one, then *happening* to notice bug 426713 more or less does it all).
(Reporter)

Comment 16

10 years ago
Resolving as a dupe of bug 426713 since the implementation is being handled over there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426713
Alex, what about bug 420232 which is still in the blocker list but isn't added on bug 426713?
No longer blocks: 405605, 425582
Status: RESOLVED → VERIFIED
Alex, what about bug 420232 which is still in the blocker list but isn't added on bug 426713?
No longer blocks: 405605, 425582
Status: RESOLVED → VERIFIED
(Reporter)

Comment 19

10 years ago
good catch, added 426713 to the list of bugs blocking 420232
No longer blocks: 420232
You need to log in before you can comment on or make changes to this bug.