can't open new composition window anymore ("An error occurred while creating a message compose window. Please try again."

RESOLVED FIXED

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Magnus Melin, Assigned: Joey Minta)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression
Bug Flags:
blocking-thunderbird3.0a1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: verified-fixed)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Try to open a composition window, new or reply.
"An error occurred while creating a message compose window. Please try again." 

From the builds forums, seen on windows, I see it on linux too.

Regression started 2008-03-30 03 -> 2008-04-01 02
<http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=ThunderbirdTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-03-30+03%3A00%3A00&maxdate=2008-04-01+02%3A00%3A00&cvsroot=%2Fcvsroot>

Just looking at the bug summaries, bug 421846 come to mind, but nothing definitive.
Flags: blocking-thunderbird3.0a1+
(Assignee)

Comment 1

10 years ago
For the record, this is why the dozens of try/catches in mailnews are so annoying.  They make debugging this really hard.

Can you try changing http://mxr.mozilla.org/seamonkey/source/mail/components/compose/content/MsgComposeCommands.js#1470 to
var errorMsg = bundle.getFormattedString("initErrorDlogMessage", ex);
so that the we actually know what the error is?  Thanks.
(Reporter)

Comment 2

10 years ago
Don't have time to build atm, but the dump statement gives
EX: = ReferenceError: sOther_headers is not defined

SeaMonkey nightlies work fine, but maybe I don't have the same settings there...
(Assignee)

Comment 3

10 years ago
Created attachment 313351 [details] [diff] [review]
patch

Really not sure how this bit slipped through, but nonetheless, here's the patch.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #313351 - Flags: review?(philringnalda)
Comment on attachment 313351 [details] [diff] [review]
patch

Tests! Tests! Tests!
Attachment #313351 - Flags: review?(philringnalda) → review+
Blocks: 421846
(In general, not "before you check this in," that is...)
(Assignee)

Comment 6

10 years ago
Checking in mail/components/compose/content/MsgComposeCommands.js;
/cvsroot/mozilla/mail/components/compose/content/MsgComposeCommands.js,v  <--  MsgComposeCommands.js
new revision: 1.129; previous revision: 1.128
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
Quick question: While I can create composition windows, and I can even save written mails to "Drafts", I can't send messages at all. Neither CTRL-ENTER, nor clicking "Send", nor "File/Send Now" work.  Is that the same bug or something different?
(Assignee)

Comment 8

10 years ago
from IRC, Marco discovered that his problem was caused by the enigmail extension, which was broken by bug 421846.  That extension depended on some of the global variables that have now disappeared.  (I'm comfortable that that kind of bustage is something enigmail should fix, rather than us.)
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED

Comment 9

10 years ago
Did Marco find a workaround?  I have the same problem, and it started at the same time (I've been using older nightlies for a few days to avoid it til I had some time) -- I used enigmail a long time ago, but uninstalled it a long time ago.  The problem goes away with a new profile, but not safe mode.
I'm using Win XP, version 3.0a1pre (2008040903), and haven't been able to send mail with a fresh nightly since around 4/1.

Comment 10

10 years ago
Current nightlies of Enigmail fix the problem for me. I worked with patrick on getting Enigmail fixed.

Comment 11

10 years ago
I didn't have enigmail installed in the first place when I had this same error message start showing up in place of a compose window.  I figured it's possible there was some kind of bad uninstall in the past, so I tried installing, testing, uninstalling, testing again with two different versions of enigmail, including the nightly, and the error hasn't gone away during any of that.  I can't find any trace left of enigmail in my profile directory, but maybe I'm just not looking hard enough.  I've uninstalled all my add-ons, now, and safe mode didn't help, either.  I tried re-creating my set-up in a new profile, but the error has made it into the new profile.  When I have more time, I can do additional experimentation with that, to see what file it comes to the new profile with, and onward from there.  A new clean profile (i.e. a useless one) does not have the problem.

Should this bug be re-opened, or should I file a new one? It did start happening to me the same time as to Magnus Melin.
(Reporter)

Comment 12

10 years ago
If you set the pref browser.dom.window.dump.enabled true and run with the "thunderbird.exe -console" option, do you see any dump message when it happens?

Comment 13

10 years ago
I get these first two lines when I click the "write" button, and the 3rd line (4th if you count a blank line) when I click "OK" on the error message. 

ex = TypeError: view is null
EX: = TypeError: b.incomingServer is null

ComposeUnload from XUL

Comment 14

10 years ago
An error happens in function FillIdentityList(menulist), when call is made to accounts.sort(sortAccounts);
When this call is commented out, the error disappears.

Comment 15

10 years ago
The bug isn't fixed. Please reopen it.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041303 Thunderbird/3.0a1pre ID:2008041303
(Reporter)

Comment 16

10 years ago
Reopening as the fix didn't fix it for everyone, at least it would seem incomingServer needs checking - http://lxr.mozilla.org/seamonkey/source/mail/components/compose/content/MsgComposeCommands.js#2265

Not sure where the other error comes from.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 17

10 years ago
Add me to the list of people where things are still broken - I tried running TB with the console open to see if I was getting the same error as others, but the console doesn't want to stay open for more than a millisecond before closing.

This is on Vista
(Assignee)

Comment 18

10 years ago
Created attachment 316702 [details] [diff] [review]
incomingServer patch

This patch will check to make sure we actually have a function account, that is, one with an incomingServer.
Attachment #316702 - Flags: review?(dmose)
Comment on attachment 316702 [details] [diff] [review]
incomingServer patch

Looks good; r=dmose.
Attachment #316702 - Flags: review?(dmose) → review+

Updated

10 years ago
Whiteboard: [needs checkin]

Comment 20

10 years ago
when will this be checked in?
(Assignee)

Comment 21

10 years ago
Checking in mail/components/compose/content/MsgComposeCommands.js;
/cvsroot/mozilla/mail/components/compose/content/MsgComposeCommands.js,v  <--  MsgComposeCommands.js
new revision: 1.132; previous revision: 1.131
done
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Whiteboard: [needs checkin]

Comment 22

10 years ago
Hmmm
I was not getting this error prior to the hourly:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042317 Thunderbird/3.0a1pre ID:2008042317

Now I can't open a composition window.

Dump:
Ex: = ReferenceError: Server is not defined.

Incidentally, how do I get the dumps to go to a file, rather than a minimized window in WinXP.
Whiteboard: [needs checkin]
(Assignee)

Comment 23

10 years ago
Bustage fix checked in for the Server is not defined error.  Thanks for the testing!

Comment 24

10 years ago
Verified-fixed
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042318 Thunderbird/3.0a1pre ID:2008042318
Whiteboard: [needs checkin] → verified-fixed
You need to log in before you can comment on or make changes to this bug.