clicking bookmarks won't open URL, must use side bar or manager

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Thomas Oskk, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Dunno if this is a dupe, couldnt find this exact issue.

When clicking bookmark from drop-down menu item, nothing happens, neither left nor right click.
Using side bar or bookmarks manager works. 


Reproducible: Always

Steps to Reproduce:
1. do as described
2. see what happens
Actual Results:  
sustains in fale-safe mode.

Expected Results:  
tab/window with URL opening

Maybe this is another bug, but since i discovered this issue, clicking the URL-text does not highlight it any more. Instead i have to click the web-site symbol besides it to highlight. This is annoying.
(Reporter)

Comment 1

10 years ago
if it helps: Right now i additionally noticed that my default "home" page has been overridden by some customized google page. 
When opening a new window, my default page opens, but clicking on "home" brings up the google search page http://www.google.de/firefox?client=firefox-a&rls=org.mozilla:en-GB:official 

Options/Main still shows my default, but it wont load on clicking the home button.
What went wrong on the last update??
Maybe deleting the file localstore.rdf in your profile wil help?
If not, you could try a new profile or a reinstall in a new empty folder.

http://kb.mozillazine.org/Corrupt_localstore.rdf
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 3

10 years ago
Wow, Ria, thanks! I renamed localstore.rdf to localstore_old.rdf, also renamed localstore-safe.rdf to localstore-safe_rdf.old and that worked out fine:

- Bookmarks are working again from menu dropdown list
- home page is the preset one
- URL gets highlighted again by clicking on it

I just had to change toolbar settings and icon size.

My profile was ok, I only have one, and there was no other one. 
Maybe one should add the symptoms I described above to the
http://kb.mozillazine.org/Corrupt_localstore.rdf
help page, as there are the non-highlighting URL, the reset home page and the not working bookmarks <U>though shown</u>. 

Thanks for the quick fix!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
The FIXED resolution is reserved for bugs with code checked in to fix a issue. Not for where someone found a workaround to their support issue.  marking as WFM
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 5

10 years ago
First: Sorry if i changed the sataus, wasnt even aware of doing that. 

Second: IT'S BACK!
As soon as i open a second browser window, the same issues as discribed before reappear. 
I think its not suitable to delete the localstore.rdf everytime i open a new window. So, this time i reopend the bug. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Maybe caused by some faulty add-on that is corrupting the localstore.rdf file? Try safe-mode to find out or try disabling the add-ons one by one.
http://kb.mozillazine.org/Safe_Mode_(Firefox)
Version: unspecified → 2.0 Branch
(Reporter)

Comment 7

10 years ago
I think, the malefactor is unmasked now: It the All-In-One-Sidebar.
Strange to say disabling did not change behavior of FF the first time.
The problem is already known there, and a temporary workaround is provided here: http://firefox.exxile.net/aios/knownissues.php
This does the trick. For now. Bookmarks are accessible as known again, URL-bar behaves like desired, "home" leads home, even when opening new window. 
Thanks for your efforts, Ria and Tracy! 
Have a nice day :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.