Ender lite doesn't send out onchange events

VERIFIED FIXED in M17

Status

()

P1
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: pollmann, Assigned: mjudge)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

18 years ago
When duping or reassigning a bug usually it goes something like:

Click inside text field labeled "Reassign bug to"
Type email address
Click Commit button

As you click the commit button, the focus will leave the text field and cause an 
onchange event to be fired.  This will select the radio to the left.

Ender Lite is not generating these onchange events as focus leaves a text input 
(It should iff text has changed).  This means the radio is never selected and 
the bug is not reassigned.

Here's a reduced test case:
<FORM>
 <INPUT TYPE=text ONCHANGE="alert('Change detected.\n');">
</FORM>

Type in the input, click elsewhere.  You should get an alert!
(Reporter)

Comment 1

18 years ago
See nsGfxTextControlFrame's nsEnderEventListener::Blur.
The code was in there to detect if the text had changed and send out an onchange 
event.
(Reporter)

Comment 2

18 years ago
In nsGfxTextControlFrame2::SubmitAttempt() You should also call the Blur method 
or otherwise check if the text has changed and send out an onchange.

(I would reopen bug 18501, but this is really a simple thing, so we can track it 
here just as well.)
(Reporter)

Comment 3

18 years ago
Nominating for nsbeta2 because this breaks a lot of sites, including regressing 
bug 18501 which was nsbeta2+
Keywords: nsbeta2, regression
(Reporter)

Comment 4

18 years ago
See also bug 42529.  Even after you get this working, you probably won't see 
bugzilla reports working until 42529 is fixed.  The simplified test case will 
work when this bug is fixed though.

Comment 5

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]

Comment 6

18 years ago
setting to m16, where + bugs live
Target Milestone: --- → M16

Comment 7

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 8

18 years ago
moving over to m17, adjusted priority and severity
Severity: major → critical
Priority: P3 → P1
Target Milestone: M16 → M17

Updated

18 years ago
No longer blocks: 43893

Updated

18 years ago
Blocks: 43893
(Assignee)

Comment 9

18 years ago
this is working except that textAREAS are not getting focus or blur events. just 
the text input fields. wont resolve bug until i figure out why.
Status: NEW → ASSIGNED

Comment 10

18 years ago
*** Bug 44083 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
dishes are dun dude.  neeeext..
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
Sweeeet...  :)  Also if not done already, please test this with bug 18501.  See 
my comment about "SubmitAttempt()" above.

Updated

18 years ago
No longer blocks: 43893

Comment 13

18 years ago
verified:

2000-07-06-09-M17 - WinNT
2000-07-06-08-M17 - Mac
2000-07-06-08-M17 - Linux
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.