Unordered list empty item bullet point wrong display

RESOLVED DUPLICATE of bug 179596

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 179596
10 years ago
8 years ago

People

(Reporter: Olivier Parent, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

OK The bullet point is displayed before the table.

<ul>
  <li></li>
</ul>
<table>
<tr>
  <th>A</th><th>B</th><th>C</th>
</tr>
</table>

FAIL The bullet point is displayed inside the table.
(empty inlined tag effect ?)

<ul>
  <li><code></code></li>
</ul>
<table>
<tr>
  <th>A</th><th>B</th><th>C</th>
</tr>
</table>


Reproducible: Always

Steps to Reproduce:
1. See the attachement or create a html file with the code in the details section

Actual Results:  
The bullet point is displayed inside the table.

Expected Results:  
Bullet point is always displayed before the table.

Bullet point should always be displayed before the table.
(Reporter)

Comment 1

10 years ago
Created attachment 313339 [details]
Test case for list item display bug

Comment 2

10 years ago
I can confirm this on today's build, but I suggest assigning this to a more specific product and component if anyone's going to see it. Seems like Core/HTML:Parser might be a good place.
Can this be considered a duplicate of bug 179596?

Comment 4

9 years ago
I can confirm this Bug on FF 3.0.4 and simplify the test code. There is no table or complicated structure that causes the problem, the following is enough:

Reproduce: render following (W3 conform) html code
<h1>Example</h1>
<ul>
  <li>
</ul>

<h1>Problem</h1>

Result: The bullet is displayed in the second heading.

Expected Result: Heading is displayed below the bullet (vertical space).
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 3.0 Branch
(In reply to comment #5)
> Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe
> mode?

As stated in comment 3, I'm considering this to be a duplicate of bug 179596. The test case is very similar (in the sense of empty list items triggering the symptom) and also Tyler hints towards this issue being fixed and my tests confirm it as well, both for stable 3.6.8 [1] and nightly 4.0b5pre
[2], on Windows Vista SP2.

Note that I have added a similar comment in bug 179596 comment 29.

[1] Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722
Firefox/3.6.8 ( .NET4.0E)
[2] Mozilla/5.0 (Windows NT 6.0; rv:2.0b5pre) Gecko/20100822 Minefield/4.0b5pre
( .NET CLR 3.5.30729)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 179596
(Reporter)

Comment 7

8 years ago
Thanks for fixing this bug.
The test is OK now.
https://bug426761.bugzilla.mozilla.org/attachment.cgi?id=313339

Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)
You need to log in before you can comment on or make changes to this bug.