Login unsuccessfull on https://webmail.belgacom.net

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: E Ceulemans, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

The console dispaly this error first followed by various warnings

Error: document.login_field_form.submit is not a function
Source File: https://webmail.belgacom.net/page.html?error=3&partner=belgacomslf&pagelang=fr
Line: 693

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 313345 [details]
page where the error occured

Comment 2

10 years ago
Resolving as INVALID. According to http://developer.mozilla.org/en/docs/DOM:form.submit

"If a form control (such as a submit button) has a name or id of submit it will mask the form's submit method."

Since on line 846 you have:

<td align="right"><input type="hidden" name="test_validation" value=""> <input name="submit" type="submit" class="form_button" value="Connexion" id="loginbutton" onclick="javascript:disable_validation_button();return false;">
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Error Console → General
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.