Cut/copy bookmark folder from left pane of bookmark organizer does not include contents

RESOLVED DUPLICATE of bug 425884

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 425884
10 years ago
8 years ago

People

(Reporter: C. Daelhousen, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

I exported some Fx2 bookmarks to import into a separate Fx3-beta5 profile. Trying to get the former 'bookmarks toolbar items' back onto the bookmarks toolbar went badly.

First, I can't drag-and-drop on the left pane to move the folders (bug 405198, maybe?). The 'Move...' menu item has no shortcut. I began to cut-and-paste the folders individually (you can't multi-select on the left) from the one folder to the other, only to have those folders lose their contents.

Reproducible: Always

Steps to Reproduce:
1. Open Fx3-beta5 bookmarks manager.
2. Open the bookmarks menu on the left pane.
3. Select a folder on on the LEFT PANE that has bookmarks in it.
4. Cut or copy (using keyboard shortcut or context menu).
5. Paste anywhere (left or right, Ctrl-V or context menu).
Actual Results:  
The pasted folder is empty.

Expected Results:  
The pasted folder should be an exact copy of the source folder tree.

Ctrl-Z only appears to undo one action (and has no UI anyway), so in the case of Cut, this is data loss. You can only undo the Paste. Your bookmarks are gone.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Fixed in nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425884
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.