reply on mail with attached images include these images in reply

RESOLVED DUPLICATE of bug 161775

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 161775
10 years ago
10 years ago

People

(Reporter: Nikolay Shopik, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: version 2.0.0.12 (20080213)

If you have enabled (which is default) View->Display Attachments Inline and receive message with any images and reply on it you have these images also in your quote.
Trunk version 3.0a1pre (2008040204) is not affected by such problem.

Reproducible: Always

Steps to Reproduce:
1.Receive mail with images attached
2.Select View->Display Attachemtns Inline option
3.Reply on this mail
4.Observe images in your quote


Expected Results:  
Images or any inline rendered information shouldn't included in your quote

Workaround: Disable View->Display Attachments Inline option - it's enabled by default!
(Reporter)

Comment 1

10 years ago
Forget to mention OS WXP SP2
Version: unspecified → 2.0

Comment 2

10 years ago
The behavior has been changed by bug 161775, which now doesn't include any attachments in replies even if visible when displaying the message. Since this was considered by others a feature rather than a bug, therefore this change as too restrictive, bug 384599 would add a preference setting to allow the user to choose whether or not to include attachments displayed inline.

This was patched on trunk but not on branch, thus you see the change with Thunderbird 3.0 only, but not in the current 2.0 releases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 161775
You need to log in before you can comment on or make changes to this bug.