Addons work, despite not being compatible

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: dewdadew2006, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/2.0.0.12;MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/2.0.0.12;MEGAUPLOAD 1.0

All my extensions from 2.0 say they are not compatible, yet when I re download them from Mozilla site, they work for 3-4 Firefox restarts and then it checks for updates and removes them.
But I can reinstall them over and over, so...

The extensions work with no flaws, but Firefox eventually removes them.
Extensions used were "Fasterfox", "Adblock Plus", Tab Mix Plus" and the theme Redshift V2 Rc1.

Reproducible: Sometimes

Steps to Reproduce:
1. install extensions/add ons from mozilla site
2. restart firefox to install add ons
3. addons now work until program updates itself
Actual Results:  
All extensions work including themes, even though at install Firefox said they were not compatible.

Expected Results:  
Rejected the extensions that were not compatible.

I wouldnt mind however these extensions working in the final build, as I wouldnt have to wait for a coder to make a new one for the new build.
I would do so myself, but I dont know much programming.
Type about:config into the address bar. In the list that appears looks for extensions.checkCompatibility. If it exists what is its value?

(Reporter)

Comment 2

11 years ago
There is no value for the given parameters.
There are extension values for each extension, but not the one you requested.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Are you still seeing this problem with Firefox 3 final? If so can you explain what you mean when you say that Firefox checks for updates and removes the add-ons.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Are you still seeing this problem with Firefox 3 final? If so can you explain
> what you mean when you say that Firefox checks for updates and removes the
> add-ons.
> 

It does not do it now, Im guessing it was a random bug in the beta.
By removes them in the updates, I meant when firefox did its periodic checks for program and extension updates it would remove any extension from itself after checking.
This may have been user specific, but for the time being it seems to be fixed.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.