Address bar doesn't look good with dark GTK themes

RESOLVED DUPLICATE of bug 409974

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 409974
10 years ago
10 years ago

People

(Reporter: Ulisse Perusin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4

The background color in the items of the so called "wonderbar" is the same of the GtkMenu widget, but the text in it uses hardcoded colors.
If you use a dark theme, such as <a href="http://art.gnome.org/themes/gtk2/1285">Darkilouche</a> or my <a href="http://art.gnome.org/themes/gtk2/1364">Clearlooks-Darklime</a>, the text becomes unreadable.
You should let the theme set the text color, and maybe mix it with some green for the URL string.

Reproducible: Always

Steps to Reproduce:
1.set a dark GTK theme
2.launch FF3
3.type something in the address bar to make appear the dropdown
Actual Results:  
it's difficult to read the text in the dropdown

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 409974
You need to log in before you can comment on or make changes to this bug.