Enable sorting in the 'Page Info' => 'Media' table

RESOLVED DUPLICATE of bug 275223

Status

()

Firefox
Page Info Window
RESOLVED DUPLICATE of bug 275223
10 years ago
9 years ago

People

(Reporter: robertmarley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre

On any site: Opening 'Page Info':
You can do this by pressing CTRL+I if you have 'page info' extension installed
or
right-click 'View Page Info'
Then click on 'Media'.
Then try to arrange the contents after 'Type'.
Pressing it, makes nothing happen.
I know it is a minor bug, but still... having a page with a lot of content it is nice to be able to arrange the contents by 'Type' instead of by 'Address' (default)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Function not working

Expected Results:  
Arrange by 'Type'

Comment 1

10 years ago
confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052707 Minefield/3.0pre

but the wording of the bug is a bit misleading - I didn't understand what it is about until I acutally went to the page info.

I think it should read more like:

[RFE] enable sorting in the "page info" => "media" table
(Reporter)

Updated

10 years ago
Alias: sasasa
(Reporter)

Updated

10 years ago
Alias: sasasa
Summary: 'View Page Info' arrange function not working → Enable sorting in the 'Page Info' => 'Media' table
(Reporter)

Comment 2

10 years ago
@1#: taken into consideration and now the title has been changed.

Hehe took me some time though to figure out how to do it.
I pressed the 'edit' button, the dropdown dropped down, I wrote the new title in 'Summary' (would be better if it said 'New title'), but then what? 
Finally I found out that you had to scroll down and press commit.

Didn't take the [RFE] part to the new title, because I'm not sure what it means. The guess I came up with was [RFE] = RequestForEdit, is that it?

P.S. if you can confirm the bug, then please mark it as 'confirmed' (or 'VERIFIED' as I think is the term used) 
(Reporter)

Comment 3

10 years ago
Is it possible to somehow edit the 'description' of the bug? 
So I can change "Then click on 'Media'" to "Then click on 'Media' table" and "arrange" to "sort"...
(Reporter)

Comment 4

10 years ago
Created attachment 323555 [details]
illustration of the bug01
(Reporter)

Comment 5

10 years ago
Created attachment 323556 [details]
illustration of the bug02
(Reporter)

Comment 6

10 years ago
Added some illustrations so one quicker can understand what the bug is about

Plus, just for the record:
the previous title of the bug was: "'View Page Info' arrange function not working"

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Component: Menus → Page Info
QA Contact: menus → page.info
This seems like a duplicate of bug 275223.
(Reporter)

Comment 8

10 years ago
Seems, that you're right. Wow this bug was reported long time ago :O (as early as 2001 according to this thread: https://bugzilla.mozilla.org/show_bug.cgi?id=76170 )

According to this thread: https://bugzilla.mozilla.org/show_bug.cgi?id=317675 the bug was not present in FF version 1.0.7 (help to developers)

In this thread: https://bugzilla.mozilla.org/show_bug.cgi?id=76170 I found this comment which might be interesting to developers:
"it looks like there are two ways to fix this. 1) Rewrite nxXULSortService, and
2) rewrite page info to use outliners instead of trees. Since 2 provies more
benefits than 1, and I'm less likely to screw anything else up by doing 2 than I
would by attempting 1, it looks like 2 is the way to go. Probably more work
though :P"

Another comment, which might interest developers (found in this thread: https://bugzilla.mozilla.org/show_bug.cgi?id=416573 ):
"The Meta treeview and the Media treeview share the same treeview implementation
(pageInfoTreeView), so I think it would be possible to fix both issues in a
single bug.
"

Also found out that for some reason (:S) on this page: http://gandalf.psych.umn.edu/users/kersten/kersten-lab/courses/Psy5038WF2003/5038Syllabus.html the 'Media' table is not there... (what the ?) (Should I make a new bug concerning this?)

I can't see why it should be wrong so here I post all the duplicates (exactly the same issue they consern) I found thanks to your link (#7):
https://bugzilla.mozilla.org/show_bug.cgi?id=275223
https://bugzilla.mozilla.org/show_bug.cgi?id=317675
https://bugzilla.mozilla.org/show_bug.cgi?id=228110
https://bugzilla.mozilla.org/show_bug.cgi?id=416556
https://bugzilla.mozilla.org/show_bug.cgi?id=416573
https://bugzilla.mozilla.org/show_bug.cgi?id=101904
https://bugzilla.mozilla.org/show_bug.cgi?id=123950

Also there are a lot of patches doing stuff to 'Page Info' here: https://bugzilla.mozilla.org/show_bug.cgi?id=52730 , but I don't understand what they do, and also I don't know how to implement a patch... 
(In reply to comment #8)

> According to this thread: https://bugzilla.mozilla.org/show_bug.cgi?id=317675
> the bug was not present in FF version 1.0.7 (help to developers)

No, the comment says that the feature was not present in 1.0.7

> Also found out that for some reason (:S) on this page:
> http://gandalf.psych.umn.edu/users/kersten/kersten-lab/courses/Psy5038WF2003/5038Syllabus.html
> the 'Media' table is not there... (what the ?) (Should I make a new bug
> concerning this?)

No, that's bug 377396.

> Also there are a lot of patches doing stuff to 'Page Info' here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=52730 , but I don't understand
> what they do, and also I don't know how to implement a patch... 
> 

Bug 52730 is marked as FIXED. These patches were applied in 2002.
What's going on with this bug? I'm still seeing the issue since it's not been fixed...
Sorry, build Id: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 ID:20090423192432

and this occurs over all platforms as well.
OS: Windows XP → All
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 275223
You need to log in before you can comment on or make changes to this bug.