Remove Windows 98, Windows NT and Mac System 9.x from Operating System drop-down menu on Enter A Bug page

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: AndrewM, Assigned: gerv)

Tracking

3.0.4
Bugzilla 3.4
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008032505 Firefox/3.0b5pre
Build Identifier: 

Spinoff from bug 426088.

Windows 98, Windows NT and Mac System 9.x should be removed from the Operating System drop-down menu on the Enter A Bug page because they are no longer commonly used and will not be supported by Firefox 3 or other Gecko 1.9-based apps.

Also, as a workaround if a new bug needs to be filed against one of those OSes the OS field can be corrected after the bug has been filed.

Reproducible: Always
AFAIK we still support Win 98 on the 2.0.0.x branch.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
I don't think we should do this.
Assignee: marcia → justdave
Status: ASSIGNED → NEW
Component: Bugzilla: Keywords & Components → Bugzilla: Other b.m.o Issues
QA Contact: timeless → reed
I'm okay with removing Mac 9.x, but we still support both Windows 98 and Windows NT and I'm not really sure of the value of doing it now.

Is this specific to the "enter a bug" page when it's not advanced? Or are you requesting we remove it for all Version drop downs? (Can the basic "enter a bug" page be customized in that way? I wasn't sure.)
yeah, the guided page has its own list.
Assignee: justdave → gerv
(Reporter)

Comment 5

10 years ago
Point taken that there really is no rush to do this now; though I certainly think it makes sense to do it once Firefox 2.0.0.x is no longer supported (which I think is about 6 months after Firefox 3 is released?)

(In reply to comment #3)
> ...
> 
> Is this specific to the "enter a bug" page when it's not advanced? Or are you
> requesting we remove it for all Version drop downs? (Can the basic "enter a
> bug" page be customized in that way? I wasn't sure.)

And just to be clear, I'm only talking about the guided page that us regular users and bug-filers see (I'm guessing on the advanced page you can choose from all the OS choices, including ones that no longer appear on the guided page like Windows 95 and Windows ME?)
Might also be worth pointing out that Firefox isn't the only product that collects bug reports on this server.  Bugzilla is known to work on Windows NT for example.
(Reporter)

Comment 7

10 years ago
So I did some Bugzilla searching to see just how often bugs are filed against Mac System 9.x, Windows 98 and Windows NT.

IMHO, this supports removing Mac System 9.x from the drop-down menu now, but leaving Windows 98 and Windows NT for the foreseeable future because a not insignificant number of people are still filing bugs against those OSes.

And perhaps it can be looked at again 6 months to a year from now. Anyway, here are the numbers:

Number of bugs filed for each of the three OSes over the last year, 3 months and month:

Mac System 9.x in the past

year:      5 bugs    https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfieldfrom=2007-04-04&chfieldto=Now&chfield=[Bug+creation]
3 months:  1 bug     https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfieldfrom=2008-01-04&chfieldto=Now&chfield=[Bug+creation]
month:     none      https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfieldfrom=2008-03-04&chfieldto=Now&chfield=[Bug+creation]


Windows NT in the past

year:      18 bugs   https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfieldfrom=2007-04-04&chfieldto=Now&chfield=[Bug+creation]
3 months:  4  bugs   https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfieldfrom=2008-01-04&chfieldto=Now&chfield=[Bug+creation]
month:     2  bugs   https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfieldfrom=2008-03-04&chfieldto=Now&chfield=[Bug+creation]


Windows 98 in the past

year:      125 bugs  https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfieldfrom=2007-04-04&chfieldto=Now&chfield=[Bug+creation]
3 months:  16  bugs  https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfieldfrom=2008-01-04&chfieldto=Now&chfield=[Bug+creation]
month:     5   bugs  https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfieldfrom=2008-03-04&chfieldto=Now&chfield=[Bug+creation]
Given the bug volumes we see, 125 bugs is fairly insignificant. And also, you haven't filtered to count only bugs filed using the Helper.

I say we can remove all three.

Gerv
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
> Given the bug volumes we see, 125 bugs is fairly insignificant. And also, you
> haven't filtered to count only bugs filed using the Helper.
> ...

I'm not sure how to filter for that.

Also, here are Bug List links that use relative date ranges:

Number of bugs filed for each of the three OSes over the last year, 3 months and month:

Mac System 9.x in the past

year:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfield=[Bug+creation]&chfieldfrom=-12m&chfieldto=Now
3 months:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfield=[Bug+creation]&chfieldfrom=-3m&chfieldto=Now
month:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Mac+System+9.x&chfield=[Bug+creation]&chfieldfrom=-1m&chfieldto=Now


Windows NT in the past

year:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfield=[Bug+creation]&chfieldfrom=-12m&chfieldto=Now
3 months:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfield=[Bug+creation]&chfieldfrom=-3m&chfieldto=Now
month:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+NT&chfield=[Bug+creation]&chfieldfrom=-1m&chfieldto=Now


Windows 98 in the past

year:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfield=[Bug+creation]&chfieldfrom=-12m&chfieldto=Now
3 months:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfield=[Bug+creation]&chfieldfrom=-3m&chfieldto=Now
month:
https://bugzilla.mozilla.org/buglist.cgi?op_sys=Windows+98&chfield=[Bug+creation]&chfieldfrom=-1m&chfieldto=Now
Created attachment 328699 [details] [diff] [review]
Patch v.1

This patch removes Windows 98, Windows NT and Mac OS 9. (Remember that there is always the "other" option.) It also adds Windows Vista, which is rather overdue.

In the course of this, I noticed that the "Mac OS X" entry was "MacOS X", and therefore gave an error when you tried to use it. Has there been a recent change in this area? How come this hasn't been noticed, I wonder? Do no Mac users file bugs using the Helper? 

Anyway, that is also fixed in this patch.

Gerv
Attachment #328699 - Flags: review?(justdave)
Attachment #328699 - Flags: review?(justdave) → review+
Fixed.

Checking in template/en/default/bug/create/create-guided.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create-guided.html.tmpl,v  <--  create-guided.html.tmpl
new revision: 1.43; previous revision: 1.42
done

Gerv
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

10 years ago
Should the fix have shown up by now? Because when I go to https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox&format=guided I still see Windows 98, Windows NT and Mac System 9.x in the drop-down.
AndrewM: I checked it in to the Bugzilla trunk. It'll show up next time b.m.o. upgrades. I don't know when the next one is planned.

Gerv
(In reply to comment #13)
> AndrewM: I checked it in to the Bugzilla trunk. It'll show up next time b.m.o.
> upgrades. I don't know when the next one is planned.

So, you checked-in a patch to Bugzilla without approval and only to the trunk, which bmo isn't going to be used any time soon.
Component: Bugzilla: Other b.m.o Issues → Creating/Changing Bugs
Product: mozilla.org → Bugzilla
QA Contact: reed → default-qa
Version: other → 3.0.4
Flags: approval?
Flags: approval3.2?
Flags: approval3.0?

Comment 15

10 years ago
This patch is OK. However, please do request approval for checkins.]

Note that *none* of the operating systems listed in that file are in the actual default list for upstream Bugzilla.
Flags: approval?
Flags: approval3.2?
Flags: approval3.0?
Flags: approval+
Reed: I checked it in to the trunk because that's the only place I have privs to check in. If you or Dave would like to give me commit access to the b.m.o. tree that would be very useful.
 
I didn't get approval because the product the bug was in didn't have the flags, and I thought that given that the project lead had seen and reviewed the patch, shifting the bug around and requesting that he come back and do more make-work seemed like process for the sake of process, and unnecessary. I did check Tinderbox, and the tree was open and green.

Gerv

Comment 17

10 years ago
(In reply to comment #16)
> and I thought that given that the project lead had seen and reviewed the patch,
> shifting the bug around and requesting that he come back and do more make-work
> seemed like process for the sake of process, and unnecessary.

Other Bugzilla managers didn't know anything about this change, because neither bugbot nor bugmail has been sent about this, as I only track bugs in the Bugzilla product. So it still makes sense to put bug reports in their correct product/component. And reed is right: next time, please ask approval before committing things. :)

Updated

10 years ago
Target Milestone: --- → Bugzilla 4.0

Updated

10 years ago
Target Milestone: Bugzilla 4.0 → Bugzilla 3.4
You need to log in before you can comment on or make changes to this bug.