If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Capslock ignored in text fields of type password

RESOLVED DUPLICATE of bug 426700

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 426700
10 years ago
10 years ago

People

(Reporter: Phil Pishioneri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040304 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008040304 Minefield/3.0pre

The capslock setting is ignored (always off) when entering text in a form field like

<input type="password" name="userinput">

and all alphabetic characters are sent as lower case.

Reproducible: Always

Steps to Reproduce:
1.Try to input an upper case letter into a password-type field by using capslock
Actual Results:  
Value sent to the server is lower case. If trying to enter a password containing upper case letters by using capslock, you cannot successfully do so.

Expected Results:  
Upper case letters, typed while capslock is active, are sent to the server.

The shift key does work. My coworker, who noticed this behavior in beta 5, says that it was working OK in beta 4. The nightly that I'm using also has the problem.

The problem does -not- exist on a Windows system using beta 5. Nor does it exist with a regular text field.

My URL is a simple php script which displays the value input into a password field upon submitting it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426700
You need to log in before you can comment on or make changes to this bug.