If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Save Link As..." fails to download the requested file where file access requires a login

VERIFIED DUPLICATE of bug 437174

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 437174
10 years ago
9 years ago

People

(Reporter: Howard Coleman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

On websites that require logins for file access,
the "Save Link As" function apparently fails to
propagate login information when it requests a file.
This generally results in a login-prompt page being 
saved to disk instead of the requested file.



- Create a login on www.washingtonpost.com.
- Browse to www.washingtonpost.com.
- Click a article headline. If the login page appears,
  type in the account name and password.
- Once the article loads (verifying that the account
  information is properly registered in the browser)
  return to the homepage, www.washingtonpost.com.
- Right-click the article headline and select
  "Open Link in New Tab". The article should open
  properly in the new tab.
- Right-click the same article headline, select
  "Save Link As ...", and specify a download location.
- The saved page will be the login page, not the
  requested article.

I believe this may occur because the download manager
fails to propagate the cookie holding the login information,
but that is speculation on my part.

Reproducible: Always

Steps to Reproduce:
1. Create a login on www.washingtonpost.com.
2. Browse to www.washingtonpost.com.
3. Click a article headline. If the login page appears,
   type in the account name and password.
4. Once the article appears (verifying that the account
   information is properly registered in the browser)
   return to the homepage, www.washingtonpost.com.
5. Right-click the article headline and select
   "Open Link in New Tab". The article should open
   properly in the new tab. This again verifies
   that you are properly logged onto the site.
6. Right-click the same article headline, select
   "Save Link As ...", and specify a download location.

Actual Results:  
The login form page was saved to disk.

Expected Results:  
The requested article should have been saved to disk.

The example used to reproduce the bug uses www.washingtonpost.com only for specificity. I have noted the problem on other websites that require logins. I've only attempted to save html pages and pdf files; both fail in the same way.

Comment 1

10 years ago
I have verified this behavior with crossword puzzles on NYTimes.com.  I am at version 3.0RC1 on Windows XP SP2.

Steps to reproduce:
1. Browse to http://www.nytimes.com/pages/crosswords/index.html
2. Click "Log in to play now"
3. Log in with NYTimes user ID and password (active crossword subscription is assumed)
4. Right-click any puzzle link (e.g., "Today's Puzzle") and choose "Save Link As..."
5. The Save As dialog appears as expected, but the file name is "index.html" when it should be e.g. "May3008.puz" 

By saving this index.html and opening in any browser, you can confirm that this is the login page as mentioned by Howard.

Comment 2

10 years ago
ETA: Simply clicking the file link will execute the configured download behavior properly.  In my case Firefox saves the file to my Downloads folder.

Comment 3

9 years ago
I can confirmed this behaviour of "Save Link As" on Firefox 3.0 on Windows when trying to download Word, pdf documents and html files.

Clicking the file will download the file correctly and launch for a word document the Word application correctly. Same for pdf and html file.

Comment 4

9 years ago
This may be the same problem as Bug 437174.  Have you got 3rd party cookies turned off, and does it work, if you turn them back on and test again?

Comment 5

9 years ago
Turning on the option "Accept third-party cookies" in the privacy options solves the problem on my side.

However, if third-party cookies are turned OFF, it is not clear, why a click directly on the link shows the documents, but the "Save as Link..." will not allow to download the document.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437174
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.