Bookmarks rearrange themselves after close/restart in Firefox 3 Beta 5

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Byron Gray, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Firefox keeps rearranging my bookmarks every time it starts.

Very annoying!!!

I have also noticed that drag/drop in the Bookmarks menu doesn't seem that responsive. It is easier to drag something down than move it up.

Reproducible: Always

Steps to Reproduce:
1. Arrange your bookmarks in a particular fashion.
2. Close and restart Firefox.
3. The bookmarks will be jumbled and mixed, even shifted between separators.


Expected Results:  
Firefox should have left my bookmarks how I arranged them.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Comment 1

10 years ago
how are you "arranging" bookmarks? with drag&drop? in the Library, in the sidebar, in the menu?
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> how are you "arranging" bookmarks? with drag&drop? in the Library, in the
> sidebar, in the menu?
> 

I'm dragging and dropped in both the sidebar and the Library. Either way they shift into an arbitrary order upon restarting the browser.

I have NOT been using any of the sorting functions, since I want the sidebar to look a specific way in a specific order.

Comment 3

10 years ago
this WFM in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008041506 Minefield/3.0pre

can you try to reproduce launching Firefox in Safe Mode? This way extensions will be disabled. Do you have any bookmark related extension?

Comment 4

10 years ago
see also bug 429083

Comment 5

10 years ago
see also bug 428828 (caused by an extension)
(Reporter)

Comment 6

10 years ago
(In reply to comment #3)
> this WFM in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre)
> Gecko/2008041506 Minefield/3.0pre
> 
> can you try to reproduce launching Firefox in Safe Mode? This way extensions
> will be disabled. Do you have any bookmark related extension?
> 

I reproduced it in Safe Mode with extensions disabled. I do not have any bookmark related extensions.

I did notice, however, that this seems only to affect the Bookmarks Menu folder. The Unfiled Bookmarks folder stays put if I rearrange it:

http://www.flickr.com/photos/9066281@N07/2419673382/sizes/l/

That shows the before photo (after I had rearranged some bookmarks in Safe Mode) and the after photo (after restarting FF in safe mode).

Also this bug only occurs (I believe) after you move a bookmark. If you don't change anything, everything will stay set from session to session.

Comment 7

10 years ago
I have ubuntu and have same problem, firefox doesñ't save changes in bookmarks, if I delete or add bookmarks after restart firefox those are missed.

Comment 8

9 years ago
Tested with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090203 Minefield/3.2a1pre Ubiquity/0.1.4

This is not reproducible for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.