Add padding to Downloads window item list

RESOLVED FIXED in mozilla1.9.2a1

Status

()

--
enhancement
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: adelfino, Assigned: dao)

Tracking

({polish})

Trunk
mozilla1.9.2a1
x86
Windows XP
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040311 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040311 Minefield/3.0pre

Add padding to Downloads window item list, it looks quite odd in Windows XP to see "empty background" (white, generally) reach the titlebar.

Don't know how this feels in Windows Vista.

Please compare screenshot and mock-up. Note that I surely didn't use the proper padding, but you get the idea.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 313481 [details]
Downloads window screenshot.
(Reporter)

Comment 2

11 years ago
Created attachment 313482 [details]
Downloads window with padding mock-up.
(Reporter)

Updated

11 years ago
Component: Download Manager → Theme
Version: unspecified → Trunk
QA Contact: download.manager → theme
If we make this change we should only do it for non-default windows themes to pick up the style in classic mode.
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> If we make this change we should only do it for non-default windows themes to
> pick up the style in classic mode.
> 

Sorry, didn't get your comment :S

Didn't try Windows Vista, but Windows XP Luna theme doesn't show something like this in any window.

So I guess this should only be ignored in Windows Vista, since I guess it does use this kind of windows.
I confirm this happens, and only in non-default windows themes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
(Assignee)

Updated

10 years ago
Component: Theme → Themes
Product: Firefox → Toolkit
QA Contact: theme → themes
(Assignee)

Comment 6

10 years ago
Created attachment 381286 [details] [diff] [review]
patch
Assignee: nobody → dao
Attachment #381286 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #381286 - Flags: review? → review?(sdwilsh)
(Assignee)

Updated

10 years ago
Attachment #381286 - Flags: review?(sdwilsh) → review?(rflint)
Attachment #381286 - Flags: review?(rflint) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

9 years ago
http://hg.mozilla.org/mozilla-central/rev/d7c4881a4f81
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.