Gdk/GLib warning/assertion messages get written to terminal window on shutdown

RESOLVED DUPLICATE of bug 422261

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 422261
10 years ago
10 years ago

People

(Reporter: myk, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Starting Firefox in a terminal on Linux (Ubuntu 7.10 in this case) and then shutting it down often results in messages like the following getting written to the terminal:

----------------------------------------------------------------------
(firefox-bin:6552): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(firefox-bin:6552): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(firefox-bin:6552): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed

(firefox-bin:6552): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed

(firefox-bin:6552): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed

(firefox-bin:6552): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.14.1/gobject/gsignal.c:2180: invalid unclassed object pointer for value type `GdkScreen'

(firefox-bin:6552): Gdk-CRITICAL **: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed

(firefox-bin:6552): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.14.1/gobject/gsignal.c:2180: invalid unclassed object pointer for value type `GdkScreen'

(firefox-bin:6552): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
----------------------------------------------------------------------

It seems like these shouldn't get written to the terminal in an optimized build.  I can't figure out why they sometimes don't get written out, but since they usually do, it's relatively easy to reproduce the problem.

Comment 1

10 years ago
dupe of bug 422261 ?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422261
You need to log in before you can comment on or make changes to this bug.