Last Comment Bug 426998 - [BC] Black lines appear between table rows when scrolling
: [BC] Black lines appear between table rows when scrolling
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: -- minor with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://membled.com/work/bugs/firefox/...
Depends on: 452319
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 04:03 PDT by Ed Avis
Modified: 2010-07-08 06:59 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the test case page on Linux Fedora 8 after scrolling (128.32 KB, image/png)
2008-04-04 04:03 PDT, Ed Avis
no flags Details
Screenshot of the test case page on Windows XP after scrolling (50.87 KB, image/png)
2008-04-04 04:04 PDT, Ed Avis
no flags Details
HTML for test case (46.09 KB, text/html)
2008-04-04 04:05 PDT, Ed Avis
no flags Details

Description Ed Avis 2008-04-04 04:03:02 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Please see the URI for a test case.  Load the document and using the scrollbar quickly scroll down to the bottom of the page.  Then scroll back up slowly.  Usually you will see a few black lines appear between table rows.

I can reproduce this on Windows XP and also on a different machine running Fedora Linux 8.  I will attach two screenshots.

Interestingly if you remove the heading and text before the table, the bug doesn't show.

Reproducible: Always

Steps to Reproduce:
1. Load the document.
2. Scroll down to the bottom.
3. Slowly scroll back to the top using the scrollbar.
Actual Results:  
1-pixel-wide black lines appear between random table rows, as shown in the two screenshots.

Expected Results:  
The display should not be altered by scrolling down and then back.

Might possibly be the same bug as #283229.  The other 'horizontal lines' bugs are not specific to table cells.  I don't see random horizontal lines in other places, only between the rows of this table when scrolling.
Comment 1 Ed Avis 2008-04-04 04:03:43 PDT
Created attachment 313580 [details]
Screenshot of the test case page on Linux Fedora 8 after scrolling
Comment 2 Ed Avis 2008-04-04 04:04:03 PDT
Created attachment 313581 [details]
Screenshot of the test case page on Windows XP after scrolling
Comment 3 Ed Avis 2008-04-04 04:04:32 PDT
One more note - I am using Firefox 3 beta 5, binary download, on both Windows and Linux.
Comment 4 Ed Avis 2008-04-04 04:05:59 PDT
Created attachment 313582 [details]
HTML for test case

Attaching the HTML in case the web site referenced goes down.
Comment 5 Dave Garrett 2008-04-04 08:06:04 PDT
Also see bug 426842
Comment 6 Ria Klaassen (not reading all bugmail) 2008-04-04 13:31:42 PDT
Confirmed on Windows XP. It is a regression between 20021029 and 20040210 and the first build was a release (Phoenix 0.4).
Comment 7 Ed Avis 2008-05-19 02:48:44 PDT
This still occurs with 3.0 rc1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0).
Comment 8 Ed Avis 2008-06-09 04:32:44 PDT
This still occurs with 3.0rc2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0).
Comment 9 Ed Avis 2008-06-20 07:00:08 PDT
This still occurs with 3.0 final (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0).
Comment 10 Ed Avis 2008-08-27 04:02:14 PDT
This still occurs with Shiretoko 3.1a1 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1) Gecko/2008072310 Shiretoko/3.1a1).
Comment 11 Ed Avis 2008-09-08 04:40:09 PDT
This still occurs with Shiretoko 3.1a2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2) Gecko/20080829082037 Shiretoko/3.1a2).
Comment 12 Daniel Holbert [:dholbert] 2008-09-08 07:27:05 PDT
I see this on Linux as well:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

OS/ Hardware --> All
Comment 13 Ed Avis 2008-09-25 00:26:46 PDT
This still occurs with Firefox 3.0.2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2).
Comment 14 Ed Avis 2008-09-29 01:18:50 PDT
This still occurs with Firefox 3.0.3 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3).
Comment 15 Ryan VanderMeulen [:RyanVM] 2008-09-29 16:40:11 PDT
Ed, no work has been done on this bug as you can tell by the fact that you're the only person commenting in it. Please stop spamming the bug unless you have something new to report. Random "this still doesn't work" messages don't help fix the bug.
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Comment 16 Ryan VanderMeulen [:RyanVM] 2008-09-30 16:32:33 PDT
Bernd, dbaron: Do either of you have an idea of what might be going on here?
Comment 17 Bernd 2008-10-01 08:36:50 PDT
typical Border collapse paint error
Comment 18 Ed Avis 2009-12-24 03:40:08 PST
Just a note to say that this bug is also reproducible on the Mac - can the bug subject line be changed?
Comment 19 Ryan VanderMeulen [:RyanVM] 2009-12-24 07:13:24 PST
Ed - FWIW, this appears to be fixed on the trunk. I can't reproduce with a current mozilla-central nightly. Given that this was fixed between the 2009-11-04 and the 2009-11-05 nightlies, it's highly likely that it was fixed by the border collapse rewrite (bug 452319).
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=41c421f97869&tochange=91e00d39570f

If you'd like to confirm this yourself, you can grab a nightly build and run it through the testcase in the bug. Note that you'll probably want to use a new profile for it as well.
ftp://ftp.mozilla.org/pub/firefox/nightly/2009/12/2009-12-24-05-mozilla-central/

It's a bit unclear at the moment which Firefox release will come next from mozilla-central, but whatever release that is will contain the fix for this bug.
Comment 20 Ed Avis 2010-01-11 09:48:05 PST
>It's a bit unclear at the moment which Firefox release will come next from
>mozilla-central, but whatever release that is will contain the fix for this
>bug.

3.6-rc1 appears not to contain the fix - does that mean these changes will not
be included until Firefox 3.7?
Comment 21 Ryan VanderMeulen [:RyanVM] 2010-01-11 13:57:27 PST
Correct, 3.6 branched off before this fix was landed on mozilla-central. It's still not certain what version of Firefox will be coming from mozilla-central next, though it appears these days that indeed it will be 3.7. Also, it's unlikely the patch that fixed this will be backported to 3.5.x/3.6.x since it was a large, complicated fix - not the kind that's typically taken into security/stability releases.
Comment 22 Ed Avis 2010-07-08 06:59:39 PDT
I'm pleased to report that this is now fixed (in Firefox 4 beta 1, Win32).  Thanks to everyone who helped with this.

Note You need to log in before you can comment on or make changes to this bug.