Profile Manager not launching separate FF2 & FF3b5

RESOLVED DUPLICATE of bug 441422

Status

()

RESOLVED DUPLICATE of bug 441422
11 years ago
5 years ago

People

(Reporter: alexis.biller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Firefox appears to now (after FF3 install) only allow one release of Firefox to run, ignoring profile manager settings.

With no firefox running. I start FF3, previous windows/tabs re-open from earlier session. When I click on my shortcut (or command line) to launch FF2 with profile "FF2" all I get is a fresh FF3b4 window. Repeated with FF3 using "-P default" parameter, same observations.

All the references to firefox.exe contain full path.
Firefox.exe is not on PATH environment variable.
Updated to FF3.b5 but no change observed. 

Reproducible: Always

Steps to Reproduce:
1. On a fresh WinXP machine I installed Firefox 3b4 for testing and feedback.
2. Installed Firefox 2 (different installation folder) as certain sites and resources would not function with FF3.
3. Created new profile for FF2, using following command to launch FF2 using separate profile:
"C:\Program Files\Mozilla Firefox 2\firefox.exe" -P FF2 
Actual Results:  
Tried the opposite route: after a restart, with no Firefox running: launch FF2. When I try to launch FF3 all I get is a new FF2 window.

Expected Results:  
open new window for firefox 2 when I launch:
"C:\Program Files\Mozilla Firefox 2\firefox.exe" -P FF2

open a different window for firefox 3 when I launch:
"C:\Program Files\Mozilla Firefox 3beta\firefox.exe" -P default 

Note: different profiles referenced in each of the above commands: "FF2" and "default"

Updated

11 years ago
Whiteboard: DUPEME
That is by design that you can only run version of Firefox on Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 3

11 years ago
Bug 441422 explains why you need -no-remote in addition to -P on Windows.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 441422
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.