If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[strict DTD] attributes of SCRIPT not in content model

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: dbaron, Assigned: rickg)

Tracking

({html4, regression})

Trunk
x86
Windows 98
html4, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
DESCRIPTION:  Linked scripts do not work for documents using the strict DTD.  It 
seems the problem is that the attributes of the SCRIPT element are not included 
in the content model.

STEPS TO REPRODUCE:
 * load attached test case

ACTUAL RESULTS:
 * nothing

EXPECTED RESULTS:
 * alert box with "hello" comes up 4 times (won't work in viewer - will see 
errors instead)

BUGGY ON:
 * Win98 mozilla 2000-06-15-08-M17
 * Linux mozilla 2000-06-15, pull around 09:00 PDT

WORKS CORRECTLY ON:
 * NN 4.x Win98

ADDITIONAL INFORMATION:
Nominating nsbeta2.  Linked scripts not working is serious.
(Reporter)

Updated

18 years ago
Keywords: 4xp, html4, nsbeta2, regression
(Reporter)

Comment 1

18 years ago
Created attachment 10195 [details]
JS file for testcase
(Reporter)

Comment 2

18 years ago
Created attachment 10196 [details]
testcase
(Assignee)

Comment 3

18 years ago
Hmm, sure enough -- let's see why.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

18 years ago
Fixed in my tree. My code was passing the wrong node to the block handler in the 
strictDTD. I verified that this works correctly for other elements that are 
handled the same way (textarea, style, script, title). 

For bug marking purposes, this isn't a regression -- since the strict DTD is new 
code. 
Whiteboard: fixed in my tree
(Reporter)

Comment 5

18 years ago
One can also see it as a regression caused by the turning on of the Strict DTD.
(Assignee)

Updated

18 years ago
Whiteboard: fixed in my tree → [nsbeta2+] fix in hand
(Assignee)

Comment 6

18 years ago
Marking nsBeta2, since this is data loss (I'm sure phil/jan would agree -- and 
if not they can yell at me when I get back in August). 
(Assignee)

Comment 7

18 years ago
Fixed by my last update. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Verified
2000-07-17-13-M17 : Linux
2000-07-17-09-M17 : WinNT & Win98
2000-07-13-08-M17 : Mac
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.