FF 3b5 crashes when changing color of a agenda in google agenda

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: bugzilla.mozilla, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9b5) Gecko/2008032600 SUSE/2.9.95-2.3 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.9b5) Gecko/2008032600 SUSE/2.9.95-2.3 Firefox/3.0b5

FF crashes every time I change the displaycolor of a agenda in google agenda.

Reproducible: Always

Steps to Reproduce:
1. Open google agenda and log in
2. Open color picker for an agenda
3. Pick color
4. Crash...
Actual Results:  
Firefox crash

Expected Results:  
Survive
Do you also crash in the safemode ?
- http://kb.mozillazine.org/Safe_Mode

Please provide a breakpad crash id from about:crashes
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Do you also crash in the safemode ?
> - http://kb.mozillazine.org/Safe_Mode
> 
> Please provide a breakpad crash id from about:crashes
> 

The problem also occurs in safemode.

I run OpenSuse 10.3 and apparently the susebuilds stripped the crashreport features. I tried running firefox in gdb but that doesn't seem succesfull, this is what i got:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7ca76d0 (LWP 12350)]
0xb6609274 in gdk_window_get_toplevel () from /usr/lib/libgdk-x11-2.0.so.0
(gdb) bt
#0  0xb6609274 in gdk_window_get_toplevel () from /usr/lib/libgdk-x11-2.0.so.0
#1  0xb66092be in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#2  0x08a08d20 in ?? ()
#3  0x087938b0 in ?? ()
#4  0xbfd37418 in ?? ()
#5  0xb66094d1 in gdk_window_process_all_updates () from /usr/lib/libgdk-x11-2.0.so.0
Backtrace stopped: frame did not save the PC


The we have to wait until someone else can reproduce this with a original Mozilla.org build which comes with breakpad.

Comment 4

11 years ago
WFM with beta 5, or nightly on Linux Ubuntu Hardy
Version: unspecified → Trunk
(Reporter)

Comment 5

11 years ago
I downloaded the mozilla build and generated a crashreport:
756ba7dc-03d1-11dd-9bc8-001b78bc73ea
(Reporter)

Comment 6

11 years ago
I also filed bug 427105. Looking at the crashreport both bugs appear in the same piece of code. I think they are the same.
Duplicate of this bug: 427105
0  	libgdk-x11-2.0.so.0.1200.0  	libgdk-x11-2.0.so.0.1200.0@0x2e274  	
1 	libgdk-x11-2.0.so.0.1200.0 	libgdk-x11-2.0.so.0.1200.0@0x2e2bd 	
2 	libgdk-x11-2.0.so.0.1200.0 	libgdk-x11-2.0.so.0.1200.0@0x2e4d0 	
3 	libgdk-x11-2.0.so.0.1200.0 	libgdk-x11-2.0.so.0.1200.0@0x2e53a 	
4 	libgdk-x11-2.0.so.0.1200.0 	libgdk-x11-2.0.so.0.1200.0@0x1487a 	
5 	libglib-2.0.so.0.1400.1 	libglib-2.0.so.0.1400.1@0x2da30 	
6 	libglib-2.0.so.0.1400.1 	libglib-2.0.so.0.1400.1@0x2f5d5 	
7 	libglib-2.0.so.0.1400.1 	libglib-2.0.so.0.1400.1@0x32971 	
8 	libglib-2.0.so.0.1400.1 	libglib-2.0.so.0.1400.1@0x32f2d 	
9 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	mozilla/widget/src/gtk2/nsAppShell.cpp:144
10 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:151
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk

Comment 9

11 years ago
please see bug 422916 comment 14

you'll need to use an opensuse build instead of a mozilla.org one (w/ debuginfo for everything. especially gdk and glib)
(Reporter)

Comment 10

11 years ago
The lib causing the trouble (libgdk-x11-2.0.so.0) appeared to be in the gtk2 package. After upgrading it to the current version (gtk2-2.12.5-1.1) the problem seems to be solved. I mark the bug being fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Updated

11 years ago
Keywords: crash
Whiteboard: DUPEME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.