Closed Bug 427104 Opened 12 years ago Closed 11 years ago

Proposal for a publicly accessible interface to the pending updates queue

Categories

(addons.mozilla.org Graveyard :: Developer Pages, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 483835
Future

People

(Reporter: nanotube, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: 

It would be very nice for developers (and possibly for the rest of the public as well) to be able to see information about the pending updates queue. When releasing a new update, one frequently doesn't know how long it will take to get it reviewed, so seeing where the update is in the queue would be helpful. 

Information that would be good to have for individual items in the queue:
item ages, position in queue, whether it is assigned or not

Statistical information about the whole queue that would be useful is: 
total number of items, average and median age of items in the queue, average and median age of all historically approved items, oldest item in queue.

While this is not of utmost importance by any means, it would be nice to have a little more openness in the update reviews process. As an additional benefit, this might encourage people to volunteer their time to review updates. :)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
One reason we haven't done this in the past is that although there is a queue, editors are not required (and do not) review in the exact order of the queue. An add-on may not work on an editor's platform, or maybe an editor only reviews Thunderbird extensions, or only themes, or maybe the editor only wants to review add-ons with names that appeal to him/her.

So seeing the queue really won't tell you anything at all about how long it will take.
It still gives /some/ inkling of what's going on, and that's better than having no idea at all. 

Plus, it will look bad for you guys to have a bunch of really old queue items in there for everyone to see, :) so I think it will spur the editors to be a little more proactive in getting to the older items. 

Right now there is no external accountability at all, and things can languish in there for months with nary a peep! (Case in point: it took about two months for my extension to get first approval out of the sandbox after I nominated it, and it had a very small codebase.)

Can't go wrong with greater transparency, that's my thinking.
Target Milestone: --- → Future
Version: unspecified → 3.2
I agree with Daniel F.  It does no harm to show the list.  It can be shown with some caveat listed above, but it does give some idea of how it works and what's happening.  Right now I can't think of a way the process could be more opaque.
Show us the list, please.

If we could see the list, developer's we would have a "To-Do List-type" incentive to help get the backlog down so that their add-on would be more likely to get reviewed - a selfish motivation to help.

Please consider making an easy way to see what step in the review process each add-on is stuck and what needs to be checked to get it through the review process. 

I could have reviewed a dozen add-ons in the time I have wasted trying to find out how long it would take my add-on to be reviewed.  I could have used my energy to help the process move forward. Instead - I have figured that if it takes anywhere as long to become an AMO reviewer as it does to get an add-on reviewed - there would be no point in waiting in yet another queue.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483835
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.