Closed Bug 427164 Opened 12 years ago Closed 11 years ago

jsdIScript.isLineExecutable should return NS_ERROR_OUT_OF_MEMORY for oom

Categories

(Other Applications Graveyard :: Venkman JS Debugger, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: johnjbarton, Assigned: timeless)

References

Details

(Keywords: memory-leak, Whiteboard: [firebug-p3])

Attachments

(1 file)

In FF3pre I get exceptions like this one

Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [jsdIScript.isLineExecutable]

for lines like this one:

if (script.isValid && script.isLineExecutable(scriptLineNo, this.pcmap_type))

1) Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040404 Minefield/3.0pre

2) Firebug 1.2a13X or 1.2 SVN >R498

3) http://speedmeter.de/

NOTE: I also get two out of memory errors so it possible that the OOM should be looked at first in case that makes the state invalid. I put depends on to the OOM report
Product: Firefox → Core
QA Contact: general → general
Duplicate of this bug: 426692
this error result only happens in OOM cases, i'll fix it, but i don't see why you think this is particularly important.
Assignee: nobody → timeless
Severity: normal → minor
Component: General → JavaScript Debugger
Keywords: mlk
Product: Core → Other Applications
QA Contact: general → venkman
Summary: jsdIScript.isLineExecutable NS_ERROR_FAILURE → jsdIScript.isLineExecutable should return NS_ERROR_OUT_OF_MEMORY for oom
Attachment #314045 - Flags: review?(caillon)
(In reply to comment #2)
> this error result only happens in OOM cases, i'll fix it, but i don't see why
> you think this is particularly important.
> 
Its important in two ways:
  1) If this is new API (throw normal) I have to re-write my code. It's not: good!
  2) The OOM is bogus and common: we need to know why.
Thanks
John.
Whiteboard: [firebug-p1]
No longer blocks: 411814
I think either this bug is fixed or the dependency on 422137 is bogus.  timeless, please weigh in?
Attachment #314045 - Flags: review?(caillon) → review+
Status: NEW → ASSIGNED
No longer depends on: 422137
Whiteboard: [firebug-p1]
Comment on attachment 314045 [details] [diff] [review]
report oom, don't leak lineMap on realloc failure

this is a small localized change to improve error reporting and oom handling in jsd. jsd is used by venkman and firebug (and iMacros...).
Attachment #314045 - Flags: approval1.9?
Comment on attachment 314045 [details] [diff] [review]
report oom, don't leak lineMap on realloc failure

only taking zero risk (e.g. css) or showstopper issues at this point.  If this
is one of those please re-nom and let me know.
Attachment #314045 - Flags: approval1.9? → approval1.9-
http://hg.mozilla.org/mozilla-central/rev/9ffef99c9aa7
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
adding to the firebug tracking list
Whiteboard: [firebug-p3]
Blocks: 472292
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.