New bookmark doesn't work

VERIFIED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Frank Harper, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4

Creating new bookmarks from within the Bookmark manager doesn't work in some folders. It does appear to work in the standard folders (Bookmarks Toolbar, etc.).

Reproducible: Always

Steps to Reproduce:
1. Click on Bookmarks/Show All Bookmarks
2. Click on Organize/New Folder... and create New Folder
3. Right click on New Folder/New Bookmark...
4. enter name and URL, click Add
Actual Results:  
The new bookmark does not appear in New Folder, or in any other bookmark folder.

Expected Results:  
New bookmark should have been created in New Folder
(Reporter)

Comment 1

10 years ago
The new bookmark is actually created at the root of the heirarchy. To see it, the user has to click on All Bookmarks.

The bug does not occur when the destination folder has a sub-folder and it is expanded.

The symptoms are quite similar to bug 367842. 
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Can someone mark this bug as duplicate of Bug 367842?
Sorry, it's not a duplicate.
This happens with the sidebar? Have you tested it with the release candidate?
I can no longer reproduce, since All Bookmarks has become read-only => WFM

Reporter please try with RC1, and re-open if still reproduceable.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

10 years ago
WFM with RC1.

I found the new bookmark organization with All Bookmarks being read-only to be counter-intuitive.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.