Closed Bug 427229 Opened 12 years ago Closed 9 years ago

Dell 3110cn PCL6 printer error (data violation)

Categories

(Core :: Printing: Output, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jjreisert, Assigned: pavlov)

References

()

Details

(Whiteboard: [closeme 2011-03-15])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Printing many web pages results in a data violation error on a Dell 3110cn printer in PCL6 mode.  This problem does not occur in IE or in Firefox 2.0.  It also does not occur if you select PostScript printing instead of PCL6.

Reproducible: Always

Steps to Reproduce:
1.  Open above URL.  If you don't get the print format right away, select Print Format.
2.  Print the page
3.  Check printer for error message
Actual Results:  
Printer LCD reports, "PDL Request 016-720, Data Violation".  And you must then press the checkmark button on the printer to delete the job.

Expected Results:  
Document should print

Printer is a Dell 3110cn Color Laser.  There are drivers for both PCL6 and PS printing.  The drivers are latest from Dell, version 16.17 (DELL_COLOR-LASER-3110CN_A04_R181675.EXE).
Component: General → Printing
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → Trunk
Most definitely a problem.   It happens 100% of the time for me with certain fonts, probably the bit mapped fonts like "Small Fonts" that are supplied with Windows.  I've attached print_pcl_err.html which generates the error for me.

Printing from IE7 or Opera 9.27 works perfectly!
Flags: blocking1.9?
Attached file Test case
Stuart: assigned this and the other font/printing bugs to you and marked blocking. Please provide an ETA ASAP, thx! :)
Assignee: nobody → pavlov
Flags: blocking1.9? → blocking1.9+
This sounds very similar to a bug in Cairo 1.6.0 that has since been fixed in 1.6.4.

Details of 1.6.0 issues here
http://lists.freedesktop.org/archives/cairo/2008-April/013747.html

Mention of fix in 1.6.4 here
http://lists.freedesktop.org/archives/cairo/2008-April/013759.html

And the bugzilla report and details here
http://bugs.freedesktop.org/show_bug.cgi?id=15348
Vlad, do we have that fix? If not, when might we get it?
Whiteboard: [fixed in upstream cairo?]
We have that fix, but that's not the fix for this -- that was a postscript backend fix.  This is on XP, so we're just rendering through GDI; your patch in bug 432411 might be relevant here.
Whiteboard: [fixed in upstream cairo?]
Decided not to block on this at the triage during the Firefox meeting.
Flags: blocking1.9+ → blocking1.9-
PCL printer "crash" appears fixed in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051008 Minefield/3.0pre", but Type1 fonts print as garbage -- bug 432071 ?
I was able to print this URL without any printer problems, using 3.0 RC1:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

http://www.boston.com/bostonglobe/ideas/articles/2008/04/06/house_of_cards?mode=PF

I've set my default printer back to the PCL6 printer, I'll follow-up if there are still problems.
do you see this issue still with version 3.6 or 4.0 beta?
Whiteboard: [closeme 2011-03-15]
I haven't seen this bug since I tested with 3.0 RC1.  Please close it.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
thanks for your response !
marking wfm without patch
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.