Closed Bug 427259 Opened 12 years ago Closed 10 years ago

Window class of dialog "MozillaDialogClass" breaks traditional screen reader dialog reading mechanisms.

Categories

(Core :: Widget: Win32, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WONTFIX
mozilla1.9

People

(Reporter: MarcoZ, Assigned: MarcoZ)

References

Details

(Keywords: access, Whiteboard: [not needed for 1.9])

Attachments

(1 file)

This change from the standard MFC "#32770" to the "MozillaDialogClass" was made in bug 265383.  I would like to change it back to the "#32770".  Traditional screen readers use the window class to recognize the window type.  They do not use the MSAA/IA2 role of DIALOG to identify dialogs.  JAWS 8.0, which si widely used still, is one of those traditional screen readers.  More modern screen reader architectures do no longer  require the window class to be "#32770", however due to the big number of screen reader users this would be a benefitial change for many visually impaired potential Firefox 3 users.

One side effect is that, in the first installer screen, the whole introductory message will be read automatically if the window class is "#32770".  Right now, JAWS 8.0 only reads the window title and the "Next >" button, but no dialog text.
Comment on attachment 313824 [details] [diff] [review]
Change the window class name back to the standard MFC "#32770"

Trivial change to the two constants.
Attachment #313824 - Attachment description: Change the window class name back to the standard MFC "# → Change the window class name back to the standard MFC "#32770"
Attachment #313824 - Attachment is patch: true
Attachment #313824 - Attachment mime type: application/octet-stream → text/plain
Attachment #313824 - Flags: review?(cbiesinger)
Comment on attachment 313824 [details] [diff] [review]
Change the window class name back to the standard MFC "#32770"

I don't think I'm the best person to review this.
Attachment #313824 - Flags: review?(cbiesinger) → review?(aaronleventhal)
Attachment #313824 - Flags: superreview?(roc)
Attachment #313824 - Flags: review?(emaijala)
Attachment #313824 - Flags: review?(aaronleventhal)
Attachment #313824 - Flags: superreview?(roc)
Attachment #313824 - Flags: superreview+
Attachment #313824 - Flags: review?(emaijala)
Attachment #313824 - Flags: review+
Comment on attachment 313824 [details] [diff] [review]
Change the window class name back to the standard MFC "#32770"

Very low-risk change. No objections from AT vendors on the newsgroup.
Attachment #313824 - Flags: approval1.9?
Comment on attachment 313824 [details] [diff] [review]
Change the window class name back to the standard MFC "#32770"

a1.9=beltzner
Attachment #313824 - Flags: approval1.9? → approval1.9+
Checking in widget/src/windows/nsWindow.h;
/cvsroot/mozilla/widget/src/windows/nsWindow.h,v  <--  nsWindow.h
new revision: 3.251; previous revision: 3.250
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040805 Minefield/3.0pre.
Status: RESOLVED → VERIFIED
Depends on: 429029
It looks like this caused bug 429029.
Marco, please back this out ASAP.
Checking in widget/src/windows/nsWindow.h;
/cvsroot/mozilla/widget/src/windows/nsWindow.h,v  <--  nsWindow.h
new revision: 3.253; previous revision: 3.252
done

Backed out.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: [not needed for 1.9]
Sionce more and more screen readers are relying on our IA2 roles, and because of the WMP plugin regression, this won't get changed back. Closing as WONTFIX.
Status: REOPENED → RESOLVED
Closed: 12 years ago10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.