Hangs before displaying print dialog when printer list contains remote printers

RESOLVED INCOMPLETE

Status

()

Core
Printing: Setup
--
major
RESOLVED INCOMPLETE
10 years ago
6 years ago

People

(Reporter: Andy Behrens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs retest with 4.0 or 3.6])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When I try to print (with ctrl-P), browser hangs while generating the printer list in the print dialog box. The printer I'm using is on another host (IPP printer on MacOS X system. That system may not be responding correctly, but it shouldn't cause Firefox to hang.

Reproducible: Always

Steps to Reproduce:
1.Type ctrl-P
2.
3.
Actual Results:  
Hangs.

Expected Results:  
Should have displayed print dialog (printer list, print pages, number of copies).

Strace shows that Firefox is hanging on a "connect" to port 631 of the printhost. After a couple of minutes it times out the connect and tries it again, apparently indefinitely.

If I remove the printhost from the network, the connect will time out and Firefox displays the print dialog as it should (with that printer being unavailable).

Timeout should be set shorter, and Firfox probably shouldn't retry in this case.

Comment 1

10 years ago
For me it doesn't hang completely, but it does take a very long time for the print dialog to come up.  I have about 6 network printers that are offline most of the time except when I am connected by VPN to a client.  When I hit "Print" in FireFox 3, it takes about 80 seconds for the "choose printer" dialog to come up.  I suspect it is the same issue - it is polling each printer and waiting too long.

Comment 2

9 years ago
I wait one minute for the print dialog to show when the printer is offline - each time I open the dialog, so could'nt one remove this bug and/or chache the printers?

Also you should display then a status bar so that I see that my browser is responsive.
When I do now accedently hit ctrl + p (without shift) I do more likely kill the firefox process then waiting for the dialog to come.

[Windows Vista]
Does it also happen in other applications?
Component: Toolbars → Printing: Setup
Product: Firefox → Core
QA Contact: toolbars → printing.setup
I'm seeing this too on Win XP Pro. However, when I try to print from notepad there is no hang.

Also, it seems to be only a problem for me with local network printers (http://192.168.*.*, and not other remote printers)

Bug 464020 seems like a dupe

(Incidentally, whenever this happens I also see something like bug 333990 for other printers.)

Comment 5

7 years ago
Can you reproduce using version 4 beta, or 3.6?
Sorry, I've moved house (and country) and no longer have a remote printer to test with. From memory I was seeing this with 3.6 though.

Comment 7

7 years ago
niklas also is not in a position to reproduce
Whiteboard: [closeme 2011-05-01][needs retest with 4.0 or 3.6]

Comment 8

7 years ago
We have in https://bugzilla.redhat.com/show_bug.cgi?id=694344 something which looks very much like a this bug. I will ask our reporter to help with testing here.

Comment 9

6 years ago
Closed per Whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-05-01][needs retest with 4.0 or 3.6] → [needs retest with 4.0 or 3.6]

Updated

6 years ago
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.