view-source with chrome URL only works before you directly open the chrome URL

VERIFIED DUPLICATE of bug 206691

Status

()

Toolkit
View Source
VERIFIED DUPLICATE of bug 206691
10 years ago
10 years ago

People

(Reporter: marcoos, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
View-source only works with chrome URLs that weren't previously opened.

Steps to reproduce:
1) restart Firefox
2) enter: view-source:chrome://browser/content/preferences/preferences.xul in the location bar
3) note that you see the preferences.xul source now
4) open pref window (or enter chrome://browser/content/preferences/preferences.xul in the location bar)
5) reload that view-soure URL from point (2)

Expected results:
1) preferences.xul source code

Actual results:
1) blank page

Reproduced this issue with:
* Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; pl; rv:1.9pre) Gecko/2008040404 Minefield/3.0pre
* Netcape Navigator/9.0.0.6 (en-US) on the same OS X

---

CCing biesi and bz, because...
<Pike> that's one sucky bug to blame biesi or bz with
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 206691
(Reporter)

Comment 2

10 years ago
v.
Status: RESOLVED → VERIFIED
I strongly urge you to look up the actual blame for this!  It sure ain't me.  I think this mess even predates my involvement with Mozilla.  ;)
yeah not my fault either :)
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.