bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't show recommended add-ons and use search functions in Korean addon manager

VERIFIED FIXED in mozilla1.9

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: channy, Assigned: mossop)

Tracking

({intl})

Trunk
mozilla1.9
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Created attachment 313905 [details]
don't show recommended addons.

In the latest Firefox 3 Korean version, Addon manager don't show recommended addons and the result of search as like attached screenshots.

I tested Japanese version, but it works. There is no differences values of extensions.getAddons.search.url and extensions.getAddons.recommended.url in about:config.
(Reporter)

Comment 1

10 years ago
Created attachment 313906 [details]
don't show the search result
Is this the same bug as bug 427304? I'm not sure, because that screenshot seems to be of you searching for an ASCII string, which should work OK.
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Is this the same bug as bug 427304? I'm not sure, because that screenshot seems
> to be of you searching for an ASCII string, which should work OK.
> 

In my investigation, profileSelection.xul contained 'style="width: 30em;"' without assigning height value. To fix it, style value must be localized in profileSelection.dtd. as like createProfije.xul and createProfile.dtd.
(Reporter)

Comment 4

10 years ago
Please ignore comment #3. I confused bug number. 
(Reporter)

Comment 5

10 years ago
(In reply to comment #2)
> Is this the same bug as bug 427304? I'm not sure, because that screenshot seems
> to be of you searching for an ASCII string, which should work OK.
> 

It seems to be another issue. In Korean version, recommended addons is not shown. In case of searching of ASCII keyword, the number of search is shown. It means Firefox get data by search from addon server. But, its result is not shown in dialog box.

Comment 6

10 years ago
I can reproduce this with the language pack on http://l10n.mozilla.org/~buildslave/trunk/, but I have no clue what happened.

I suspected something like bug 424081, but the URL itself seems to be fine.

I see a problem in the reporterOverlay, which I blame on the Korean localization, but I doubt that has something to do with this bug.
(Assignee)

Comment 7

10 years ago
This is an issue with how we check whether an extension in the results is compatible with the current application. We currently use the application name to compare and unfortunately AMO is returning a localised version of the name which does not match the unlocalised name in nsIXULAppInfo.

Laura, we talked about this before but apparently it never happened, can we get the application guid ({ec8030f7-c20a-464f-9b0e-13a3a9e97384} for Firefox f.e.) included in the application block?
Flags: blocking-firefox3?
(Assignee)

Comment 8

10 years ago
Created attachment 314098 [details] [diff] [review]
EM patch rev 1

From IRC, Laura will add the application <guid> element as part of the <application> block that should hopefully go live tomorrow evening. This patch switches to use it for matching.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #314098 - Flags: review?(robert.bugzilla)
(Assignee)

Comment 9

10 years ago
Comment on attachment 314098 [details] [diff] [review]
EM patch rev 1

Forgot the tests...
Attachment #314098 - Attachment is obsolete: true
Attachment #314098 - Flags: review?(robert.bugzilla)
(Reporter)

Updated

10 years ago
Depends on: 415614

Updated

10 years ago
Blocks: 415614
No longer depends on: 415614
(Assignee)

Comment 10

10 years ago
Created attachment 314397 [details] [diff] [review]
EM patch rev 2

We've decided to use appID as the guid element and the schema version is updating to 1.1. This patch is fairly trivial, just also need to update the tests to match the new schema.
Attachment #314397 - Flags: review?(robert.bugzilla)
Attachment #314397 - Flags: review?(robert.bugzilla) → review+

Comment 11

10 years ago
API changes in r12071.
(Assignee)

Comment 12

10 years ago
Comment on attachment 314397 [details] [diff] [review]
EM patch rev 2

Seeking approval to land this fix for the get add-ons pane in localised versions.

This is a very small low-impact patch that can only affect the get add-ons pane. The unit tests are there verifying that the change is doing what it is supposed to do and I have verified that AMO has been updated to match what the patch expects.
Attachment #314397 - Flags: approval1.9?
Version: unspecified → Trunk

Updated

10 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: intl
Whiteboard: [has patch][has reviews]
Comment on attachment 314397 [details] [diff] [review]
EM patch rev 2

a1.9=beltzner
Attachment #314397 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 14

10 years ago
Checking in toolkit/mozapps/extensions/src/nsAddonRepository.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/src/nsAddonRepository.js,v  <--  nsAddonRepository.js
new revision: 1.5; previous revision: 1.4
done
Checking in toolkit/mozapps/extensions/test/unit/data/test_bug404024.xml;
/cvsroot/mozilla/toolkit/mozapps/extensions/test/unit/data/test_bug404024.xml,v  <--  test_bug404024.xml
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/mozapps/extensions/test/unit/data/test_bug417606.xml;
/cvsroot/mozilla/toolkit/mozapps/extensions/test/unit/data/test_bug417606.xml,v  <--  test_bug417606.xml
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/mozapps/extensions/test/unit/data/test_bug424262.xml;
/cvsroot/mozilla/toolkit/mozapps/extensions/test/unit/data/test_bug424262.xml,v  <--  test_bug424262.xml
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
Target Milestone: --- → Firefox 3

Comment 15

10 years ago
Verified fix on Mozilla/5.0 (Windows; U; Windows NT 5.1; ko; rv:1.9pre) Gecko/2008050806 Minefield/3.0pre
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

10 years ago
Created attachment 322520 [details]
Add-on manager search in Korean

I found a problem to search addons with translated text into Korean.
In case of Foxmarks bookmark syncronizer (https://addons.mozilla.org/ko/firefox/addon/2410), it didn't show proper search result in addon manager of Firefox 3 RC1 ko version.

Comment 17

10 years ago
Well, foxmarks is only compatible with fx2, not 3, so this seems to be the right behaviour. I get the incompatible message in my en-US build, too.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.