Flexible space in main menu does not appear for popup windows

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Alan Thomas, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When I open a popup window with no menus (see bug 422590 for more info), the flexible space between the menu bar and throbber vanishes. When in Customize mode, however, it appears correctly, as the white box. (Although Customize is broken, see bug 422590 again.)

Reproducible: Always

Steps to Reproduce:
Above.
Actual Results:  
Above.

Expected Results:  
The menubar should have appeared as with a normal window.

Default theme.
Occurs with no add-ons enabled.
Alex, does that also occur under Linux? I could believe.

Confirming bug with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008040907 Minefield/3.0pre ID:2008040907
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Flexible space does not appear in menuless popup windows in Firefox 3.0b5 → Flexible space in main menu does not appear for popup windows
Version: unspecified → Trunk

Comment 2

10 years ago
Confirmed on Linux with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041004 Minefield/3.0pre
OS: Windows XP → All

Comment 3

10 years ago
Created attachment 314875 [details]
screenshot of the bug

Updated

10 years ago
Attachment #314875 - Attachment description: screenshot on the bug → screenshot of the bug
So its possibly a regression? Aleksej are you able to track it down? As I remember you have mostly all archives on your local disk?
Keywords: qawanted

Comment 5

10 years ago
I don't think this is a regression. Toolbarsprings have the "chromeclass-toolbar-additional" class, and xul.css hides these elements (window[chromehidden~="toolbar"] .chromeclass-toolbar-additional { display: none; }).

Comment 6

10 years ago
Regression range: 2007111204…2007111304. Bug 393581 fits comment #5.
(In reply to comment #6)
> Regression range: 2007111204…2007111304. Bug 393581 fits comment #5.

CC'ing Florian, who has written the patch on bug 393581...
Keywords: qawanted → regression

Updated

10 years ago
Blocks: 393581
We can just back out the part of bug 393581 that affected spacers, right?
Created attachment 315368 [details] [diff] [review]
patch v1

(In reply to comment #8)
> We can just back out the part of bug 393581 that affected spacers, right?
> 

yes.
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #315368 - Flags: review?(gavin.sharp)
We should remove it for both spacer and spring, right? They're both invisible elements.
(In reply to comment #10)
> We should remove it for both spacer and spring, right? They're both invisible
> elements.
> 

No, spacers are visible because they have a fixed width.
(Reporter)

Comment 12

10 years ago
I am a bit of a novice to the processes of Bugzilla, as you might have noticed. I am just wondering what's currently happening with this bug. Has the patch been applied? Is the problem fixed? Or are we waiting for something to happen?
Gavin, is the patch getting lost from your review list?
(In reply to comment #11)
> No, spacers are visible because they have a fixed width.

I don't see how that distinction is relevant. Both are spacers, the only difference is what width they have. If people want their flexible spacers to show up in popups, why wouldn't they want their fixed-width spacers to show up?
what's the review status here?
Whiteboard: [has patch][needs review gavin]
The question in comment 14 hasn't been answered. Florian?
Attachment #315368 - Flags: review?(gavin.sharp) → review-
Comment on attachment 315368 [details] [diff] [review]
patch v1

r- pending an answer to comment 14.
Whiteboard: [has patch][needs review gavin]
(In reply to comment #14)
> (In reply to comment #11)
> > No, spacers are visible because they have a fixed width.
> 
> I don't see how that distinction is relevant. Both are spacers, the only
> difference is what width they have. If people want their flexible spacers to
> show up in popups, why wouldn't they want their fixed-width spacers to show up?

IIRC, I assumed that fixed width spacers are used to visually separate toolbarbuttons and that flexible width spacers are used to align things, like the throbber in the screenshot attached. So it was logical to hide the former, because there is no need to separate buttons that are hidden, and the latter should be kept even when buttons are hidden.

I'm not sure if this assumption really makes sense but anyway, I'm not going to have time to work more on this in the near future so anyone interested can feel free to take it. Sorry for the lack of responsiveness.
Assignee: florian → nobody
Status: ASSIGNED → NEW
(Reporter)

Comment 19

7 years ago
This issue still exists in Firefox 4.0b6. However, it is not so important any more, as the default menu bar configuration no longer has a flexible space or throbber on it. (And, of course, the menu bar is going to be eaten by the Firefox button eventually.)
(Reporter)

Comment 20

4 years ago
This bug seems to have been fixed somewhere along the line. Could someone else confirm and close this bug?
I will close this issue as WFM per comment 20.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.