Closed Bug 427488 Opened 15 years ago Closed 13 years ago

Large Wikipedia page crashes Firefox and X

Categories

(Core Graveyard :: GFX: Gtk, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: pts+bmo, Unassigned)

References

()

Details

(Whiteboard: NOTOURBUG BUGYOURXVENDOR)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9pre) Gecko/2008040604 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9pre) Gecko/2008040604 Minefield/3.0pre

When Firefox tries to display the Wikipedia page [Wikipedia:Sounds/list], it crashes and takes everything in sight with it.  X restarts, other things are just killed.


Reproducible: Always

Steps to Reproduce:
1. Save!  You're going to lose your work.
2. Go to the URL.
3. Watch X restart.

Actual Results:  
Firefox crashes, the screen flips to tty1 for a sec (2-3 seconds with lots of tabs and windows, barely at all on a clean profile), then X comes back with the GDM login screen.  Firefox and all the other programs you had open are gone.


Expected Results:  
The page should load and display properly.


This works with a clean profile.  There was no chance for the Mozilla Crash Reporter to ask me about things; every program I had open was killed.

If you load the page in a background tab, it loads fine, but crashes as described above if you switch to that tab.

The page loads OK in Fx2, and seems to be just one giant table.
Version: unspecified → Trunk
WFM

KDE 4.03 - Kubuntu Hardy Alpha
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008040804 Minefield/3.0pre

Things to consider: My 32bit vs. Your 64bit <- Is this a valid point? Any other 64bitters out there care to volunteer your unsaved work? :)

Attaching snapshot, not that you don't believe me.
Attached image WFM - 32bit
confirmed, we saw the same bug today on IRC while testing a big page (1MB of table) and I found this bug while checking if it had not been already filed.

Here is what daemon.log has to say when it crashes:
pascal-laptop gdm[14521]: WARNING: gdm_slave_xioerror_handler : erreur X fatale - Redémarrage de :0 

(= fatal X error - restarting :0)

This was confirmed on both seamonkey 2 and Firefox 3 trunk builds, works fine in Firefox 2.

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9pre) Gecko/2008040704 Minefield/3.0pre ID:2008040704

It was confirmed on two Ubuntu Gutsy machines.
Status: UNCONFIRMED → NEW
Ever confirmed: true
So confirmed by a 32bitter and 64bitter. Both of your Build IDs are the same, I was pretty sure mine was the most recent...

Are you sure your trunk build is the most recent?
pascalc@gmail.com: please don't confirm bugs caused by OS software failures, they're not our fault.

reporter: please file a bug against your xserver and report the bug's url here.
Duplicate of this bug: 431016
Component: General → GFX: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Whiteboard: NOTOURBUG BUGYOURXVENDOR
Same issue when refresh this page :
http://fr.wikipedia.org/wiki/Discussion_Projet:Communes_de_France

I have only this issue on Wikipedia.

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3

Is the same bug ?
(In reply to comment #7)

But this link does not hang Firefox : 
http://fr.wikipedia.org/wiki/Discussion_Projet:Communes_de_France#check_list_pour_les_labels

The issue occurs only when the start of this page is displayed with or without refreshing.
Product: Core → Core Graveyard
(In reply to comment #7)
> Same issue when refresh this page :
> http://fr.wikipedia.org/wiki/Discussion_Projet:Communes_de_France

I have not still this issue with this URL perhaps because the page have changed. And http://en.wikipedia.org/wiki/Wikipedia:Sounds/list URL does not still exist.

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.