Status

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: msurdi, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13
Build Identifier: 2.0b

I've followed the installation instruction but when I run checksetup.pl i get the following error:

An error occurred processing hook db_schema-abstract_schema in
    extension ./extensions/testopia: Modification of a read-only value attempted at ./extensions/testopia/code/db_schema-abstract_schema.pl line 6.


Ask me if you need more specific details about this.

Thanks a lot.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Which version of Bugzilla?
(Reporter)

Comment 2

11 years ago
3.0.2
(Assignee)

Comment 3

11 years ago
If you are upgrading from 1.3 you should first reverse the old 1.3 patch-3.0 and then apply the current patch-3.0, not the 3.0.x. Otherwise, on a new install, be sure to use the patch-3.0.x.

(Reporter)

Comment 4

11 years ago
I've already reversed the old 1.3 patch-3.0.

So, as far as I understand, despite I'm using 3.0.2 as I'm upgrading from testopia 1.3 I should apply the patch found in testopia-2.0/patch-3.0 and not patch-3.0.x (after have reversed the 1.3/patch-3.0, of course)

Is that correct?

Do you mean that patch-3.0.x if just for new bugzilla installations or for new testopia installations ?

Sorry, but I'm a bit confused.

Thanks a lot for your help.

(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> I've already reversed the old 1.3 patch-3.0.
> 
> So, as far as I understand, despite I'm using 3.0.2 as I'm upgrading from
> testopia 1.3 I should apply the patch found in testopia-2.0/patch-3.0 and not
> patch-3.0.x (after have reversed the 1.3/patch-3.0, of course)
> 
> Is that correct?
Correct. The problem is if you are upgrading from 1.3, reversing the patch removes the bugzilla fix that was in the 3.0 patch. 

> 
> Do you mean that patch-3.0.x if just for new bugzilla installations or for new
> testopia installations ?
> 
> Sorry, but I'm a bit confused.
> 

Basically: 
upgrading from 1.3: reverse 1.3 patch-3.0 => apply 2.0 patch-3.0 regardless of bugzilla version (3.0 or 3.0.x)

New installation: installing bugzilla 3.0 use patch 3.0
installing 3.0.x use patch-3.0.x

I know this is confusing. I need to come up with a better way of dealing with this besides patching. I am open to suggestions.

I will update this in the docs and close this bug when it is done.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

10 years ago
readme updated
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.