configure fails to check for existence of wpapi.h (Parental Controls on Windows)

VERIFIED DUPLICATE of bug 425979

Status

()

--
major
VERIFIED DUPLICATE of bug 425979
11 years ago
11 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Reproduction:
1. Take a build environment which was working fine for building
   xulrunner 1.9a/b1/whatever, but does not have an SDK for
   Parental Controls on Windows.
2. Update Mozilla source
3. Try to build xulrunner again

Actual result:
c:\xulrunner_build\source\toolkit\components\parentalcontrols\src\nsPare
ntalControlsServiceWin.h(53) : fatal error C1083: Cannot open include
file: 'wpcapi.h': No such file or directory

Expected result:
a) Firefox components are in Firefox, not toolkit/.
   xulrunner does not build Parental Controls
b) configure checks for the existence of all build dependencies. If an
   external dependency on a lib or SDK is missing, configure
   shows an error with to "Either install the Parental Controls for
   Windows SDK or disable it via --disable-however-the-flag-is-called".
(Reporter)

Updated

11 years ago
Blocks: 393966

Comment 1

11 years ago
This is what bug 425979 is about.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425979
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.