panel with noautohide="true" receives no click events in Windows

VERIFIED DUPLICATE of bug 390178

Status

()

VERIFIED DUPLICATE of bug 390178
11 years ago
11 years ago

People

(Reporter: pdgiddie+mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

3.04 KB, application/x-xpinstall
Details
416 bytes, application/vnd.mozilla.xul+xml
Details
793 bytes, application/x-javascript
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040604 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040604 Minefield/3.0pre

Click event listeners for child elements are not called in Windows when a panel has the attribute noautohide="true".  I'll attach XUL, JS, and example XPI to illustrate the problem.

Reproducible: Always

Steps to Reproduce:
1. install XPI
2. Click on the popup that read "click me" in the bottom-right hand corder.
Actual Results:  
Nothing happens.

Expected Results:  
The label changes to read "clicked 1".
(Reporter)

Comment 1

11 years ago
Created attachment 314100 [details]
XPI that demonstrates the problem
(Reporter)

Comment 2

11 years ago
Created attachment 314101 [details]
XUL overlay from XPI
(Reporter)

Comment 3

11 years ago
Created attachment 314102 [details]
JS overlay from XPI
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390178
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.