nsFrame::Release called by nsTreeBoxObject::GetIndexOfItem

VERIFIED FIXED

Status

()

Core
XUL
P3
minor
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: dbaron, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
DESCRIPTION:  If you use the up and down arrows in the profile manager, WARNINGs 
are spit out that nsFrame::Release is being called (which is bad since frames 
aren't refcounted).

STEPS TO REPRODUCE:
 * In a debug build, with multiple profiles set up, start ./mozilla
 * click on one of the profiles
 * hit the up or down arrows

ACTUAL RESULTS:
WARNING: not supported for frames, file nsFrame.cpp, line 283
repeated many times

BUGGY ON:
 * Linux mozilla build of 2000-06-15, 9am PDT

ADDITIONAL INFORMATION:
Stack trace:
#0  nsDebug::Warning (aMessage=0x415d2844 "not supported for frames", 
aFile=0x415d2808 "nsFrame.cpp", aLine=283) at nsDebug.cpp:275
#1  0x411ec024 in nsFrame::Release (this=0x839eb38) at nsFrame.cpp:283
#2  0x413fff32 in nsTableFrame::Release (this=0x839eb38) at nsTableFrame.cpp:184
#3  0x4145fc6e in nsTreeFrame::Release (this=0x839eb38) at nsTreeFrame.cpp:88
#4  0x415a9dec in nsCOMPtr<nsITreeFrame>::~nsCOMPtr (this=0xbfffdb24, 
__in_chrg=2) at ../../../../dist/include/nsCOMPtr.h:489
#5  0x414391dc in nsTreeBoxObject::GetIndexOfItem (this=0x84155b0, 
aElement=0x83dee64, aResult=0xbfffdcc0) at nsTreeBoxObject.cpp:176
#6  0x401338a9 in XPTC_InvokeByIndex (that=0x84155b0, methodIndex=8, 
paramCount=2, params=0xbfffdcb0) at xptcinvoke_unixish_x86.cpp:159

nsTreeBoxObject has an nsCOMPtr<nsITreeFrame>, which doesn't make sense since 
frames aren't refcounted.
(Assignee)

Comment 1

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
verified, we don't use a comptr there now.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.