If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Older in-product pages have rendering problems

VERIFIED DUPLICATE of bug 431591

Status

www.mozilla.org
General
VERIFIED DUPLICATE of bug 431591
10 years ago
5 years ago

People

(Reporter: clouserw, Assigned: sgarrity)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Specifically, these two are messed up:

https://www-firefox3.stage.mozilla.com/en-US/firefox/2.0.0.12/firstrun/
https://www-firefox3.stage.mozilla.com/en-US/firefox/2.0.0.12/releasenotes/
(Assignee)

Comment 1

10 years ago
I can clean up the Release Notes page. A see a few options for the First Run page:

1. Create copies of the old CSS files/images for them to point to to preserve their old look. This would be a bit of a pain to keep all the old CSS/images around.

2. Update their designs to work with the new site style. This would take a bit of time.

3. Replace the old first run pages with a simple (non-version-specific) version of the new 3.0 First Run page.

John?

Comment 2

10 years ago
Thanks Steven. #3 seems like the right choice to me...is there a compelling reason not to do that one? 
(Reporter)

Comment 3

10 years ago
I would love to collapse all the 2.x in-product pages into one set of pages with a redirect once FF3 launches.  This would get rid of a lot of files on mozilla.com.  If we're going to be replacing the pages anyway, can we just make one set of pages that say "Great, you installed firefox, now upgrade to FF3" and delete all the other ones?

Comment 4

10 years ago
(In reply to comment #3)
> I would love to collapse all the 2.x in-product pages into one set of pages
> with a redirect once FF3 launches.  This would get rid of a lot of files on
> mozilla.com.  If we're going to be replacing the pages anyway, can we just make
> one set of pages that say "Great, you installed firefox, now upgrade to FF3"
> and delete all the other ones?
Excellent, let's absolutely do that then. Steven, what content info do you need from me?
(Assignee)

Comment 5

10 years ago
(In reply to comment #3)
> I would love to collapse all the 2.x in-product pages into one set of pages
> with a redirect once FF3 launches...

Perhaps we could base this page off the https://www-firefox3.authstage.mozilla.com/en-US/firefox/3.0/whatsnew/ page? It already deals with that "you've installed firefox, but it's ye olde..." case. John, if you can let me know any differences in text from that /whatsnew/ page, we can do that.

Wil, do you want to redirect all of the 2.x pages to one /2/firstrun page? Have something in mind for that?
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> Wil, do you want to redirect all of the 2.x pages to one /2/firstrun page? Have
> something in mind for that?

Something simple and generic.  Maybe add a twist of "You think FF2 is cool, get a load of FF3" to the original: https://www-firefox3.authstage.mozilla.com/en-US/firefox/2.0/firstrun/

I was hoping to get rid of all the 2.x.x.x directories on moz.com but I forgot about releasenotes.  As far as I know that's the only place we have them so we'll have to keep them around.  I still support condensing firstrun and whatsnew though.  I'm happy to write the redirects if you've got a place for me to redirect to.

Also, CCing pascal for L10n considerations.

Comment 7

10 years ago
Hey guys. Here's my suggested copy for the new Firefox 2 what's new and first run pages...if I'm missing any key issues here (quite possible) please let me know. 

First Run headline - Thanks for downloading Firefox. However, you've installed an outdated version.

What's New headline - Thanks for updating your Firefox. However, the version you've installed is still out of date.

Subhead for both - We strongly suggest _downloading Firefox 3_ for the latest updates in security, performance and features.

(the additional blurbs on each page can stay the same as their FF3 counterparts)

Copying Beltzner on this b/c he's good at editing this stuff. Mike, please give your thumbs up or suggested changes before Steven works his magic.

Thanks all-
John
(Assignee)

Comment 8

9 years ago
Marking this as a dupe of Bug 431591.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 431591
Verified dup
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.