Error with focus handling while dragging links, can cause a crash

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: albertoavila, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I´ve seen two problems:

1.- If you are dragging a link, and then a alert box is displayed the mouse stops working, you cannot close the alert window with it, you need to close it with the keyboard

2.- If you are dragging a link, and then a download dialog pops up firefox crashes.

Reproducible: Always

Steps to Reproduce:
First error:

1. Goto test url: http://albertein.gamersla.net/firefox-bug/crash.html
2. Click first link and the start dragging the same link, after one second a alert window will pop up and the mouse will become useless


Second error:
1. Goto test url: http://albertein.gamersla.net/firefox-bug/crash.html
2. Click second link and the start dragging the same link, after one second a download dialog will pop up and firefox will crash
Thanks for reporting. These two issues probably need separate bug reports - please see http://developer.mozilla.org/en/docs/Bug_writing_guidelines for reference.

For the bugs:
1) confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031905 Minefield/3.0b5pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040805 Minefield/3.0pre

this may be a duplicate of another bug, but I haven't searched thoroughly yet.

2) confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040805 Minefield/3.0pre
no crash with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031905 Minefield/3.0b5pre

bp-df4187d1-0573-11dd-811b-001cc4e2bf68

stack:
0  	xul.dll  	nsNativeDragTarget::ProcessDrag  	 mozilla/widget/src/windows/nsNativeDragTarget.cpp:237
1 	xul.dll 	nsNativeDragTarget::DragEnter 	mozilla/widget/src/windows/nsNativeDragTarget.cpp:295
2 	ole32.dll 	ole32.dll@0x118fa6 	
3 	ole32.dll 	ole32.dll@0x119107 	
4 	ole32.dll 	ole32.dll@0xf0153 	
5 	ole32.dll 	ole32.dll@0xf0388 	
6 	ole32.dll 	ole32.dll@0xf048f 	
7 	xul.dll 	nsDragService::StartInvokingDragSession 	mozilla/widget/src/windows/nsDragService.cpp:314
8 	xul.dll 	nsDragService::InvokeDragSession 	mozilla/widget/src/windows/nsDragService.cpp:263
9 	xul.dll 	nsBaseDragService::InvokeDragSessionWithImage 	mozilla/widget/src/xpwidgets/nsBaseDragService.cpp:256
10 	xul.dll 	nsContentAreaDragDrop::DragGesture 	mozilla/content/base/src/nsContentAreaDragDrop.cpp:822

This is almost certainly a duplicate of bug 427143

This bug should be marked invalid, but I won't do that until part 1 either has a new bug filed for it or a duplicate found.
Cool! Thanks for that testcase. I tried to make a testcase that didn't need enhanced privileges, but I failed.
But your testcase, crashes just fine without the use of enhanced privileges.
It's indeed very likely the same as bug 427143.
Status: UNCONFIRMED → NEW
Depends on: 427143
Ever confirmed: true
(Reporter)

Comment 3

11 years ago
Well, the first case seems to be a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=100180

Should i post my test cases on 100180 and 427143 instead?
The crash is fixed for me, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041107 Minefield/3.0pre


So marking this bug fixed.

Bug 100180 already has a testcase, so no need to post another testcase there, but thanks anyway.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.