GMail goes blank when you try to close the window (with "warn on multiple tab close" pref set)

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Unassigned)

Tracking

({dataloss, regression})

Trunk
dataloss, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 -
blocking1.9.0.1 -

Firefox Tracking Flags

(Not tracked)

Details

STR:
  1. Login to Gmail at gmail.com
  2. Open another tab (anything will do)
  3. Ensure you have the "Warn me when closing multiple tabs" pref checked
  4. Click the close button
  5. Press cancel

AR:
  The tab with Gmail in it becomes blank.

ER:
  Gmail is shown.

This is a regression from branch. Reproduced on Mac OS X 10.5 and Windows Vista.
Flags: blocking1.9?

Updated

10 years ago
Duplicate of this bug: 422871
This happens even when the tab isn't in the foreground, which is pretty strange and will make it hard for users to associate the "my Gmail went kapoof" event with the "I clicked cancel" event.

Do we know how showing that warning dialog could be interfering with GMail's code?

Tricksy issue. I'm leaning towards believing this is a blocker as it's a top 10 web application and a regression from our previous behaviour.
Bug 422871 indicates that this has been around since beta4, and we haven't seen a lot of dupes, so might not need to block. Sorry to be wishy-washy. This sort of thing really confuses me, though - I'm not sure why it would affect only that one tab ...
After walking through this, there was concern that data loss could happen (like when editing an email); however, if the user is editing an email, whether or not the tab is in the foreground, a warning will appear, and gmail doesn't go blank.  

Given that there's no data loss, and there's a work around (reload), I think this should be wanted1.9.0.x+.  Yes, high profile, but takes a few steps to reproduce. 
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-
Moving this to DOM so JST and Jonas have this on their list of things to look at next.
Component: General → DOM
QA Contact: general → general

Comment 6

10 years ago
On linux this happens also when gmail is in the foreground.

Comment 7

10 years ago
We seem to dispatch beforeunload (but not unload) event before showing the
"Confirm close" dialog. On 18 branch the event isn't dispatched before the 
dialog. Locally commenting out beforeunload event dispatch fixes this.
A regression range for this would be great.
Did a quick check and it has been like this on trunk since at least 1st July 2007, look earlier than this for the proper regression range. 

This only happens with the new v2 version of Gmail  - it does not happen with the older version.

Comment 9

10 years ago
My guess is Bug 383760, which moved browser.warnAboutClosingTabs(true) to
happen after ds.contentViewer.permitUnload().
That would mean not a DOM but Firefox bug.
Works: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007061504 Minefield/3.0a6pre

Whiteness: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007061604 Minefield/3.0a6pre

Checkins to module PhoenixTinderbox between 2007-06-15 03:00 and 2007-06-16 05:00 :
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-06-15+03&maxdate=2007-06-16+05&cvsroot=%2Fcvsroot

Wouldn't like to make a guess. I'll see if I can get my hands on some hourlies to narrow the range down.
(In reply to comment #9)
> My guess is Bug 383760, which moved browser.warnAboutClosingTabs(true) to
> happen after ds.contentViewer.permitUnload().
> That would mean not a DOM but Firefox bug.

Why would changing the order that those are called in cause the screen to go blank?

Updated

10 years ago
Blocks: 383760

Comment 13

10 years ago
(In reply to comment #11)
> Why would changing the order that those are called in cause the screen to go
> blank?
Because IIRC permitUnload dispatches beforeunload event, which is handled
in gmail.
note that after the STR from comment #0 the throbber for the gmail tab keeps spinning
This bug occurs if you attempt to quit via the red X or Alt+F4 but not if you using File | Exit.

Comment 16

10 years ago
i don't know if this is related, but i have noticed that when i click on 'download' attachment link from a gmail mail, the download begins but then the gmail page becomes completely blank.
using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051202 SeaMonkey/2.0a1pre
This bug happens to me when I try to close the window, not when I click Cancel.

@Beltzener (Comment #1): 
This happens to me (I have Windows XP) also if Gmail _is_ in foreground. 

@Sicore (Comment #4):
If you compose a mail entering some text, Gmail alerts you that you are quitting the page. So I think it's a GMail JS problem. Can someone ask to GMail team?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052901 Minefield/3.0pre

Comment 18

10 years ago
Confirmed this issue in FF 3.0rc2 and 3.0rc3, on Windows XP.

Doesn't matter whether or not GMail tab is in foreground.

Agreed, the GMail tab goes white as soon as Close Window is clicked, not when you cancel the close operation.

Updated

10 years ago
Duplicate of this bug: 440104
Flags: blocking1.9.0.1?
Summary: gmail goes blank when canceling window close (with "warn on multiple tab close" pref set) → GMail goes blank when you try to close the window (with "warn on multiple tab close" pref set)
Whiteboard: [comment 17: Tech Evang?]
Mano/mwu: comment 12 implicates bug 383760. Any easy way to fix?
Flags: blocking1.9.0.1? → blocking1.9.0.1-
Whiteboard: [comment 17: Tech Evang?]

Comment 21

10 years ago
Regarding the data loss, the gmail chat history disappers as reloading the page makes relog into the gchat.
Adding dataloss keyword per comment 21
Keywords: dataloss

Comment 23

10 years ago
I confirm the bug in

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

Running on Ubuntu 8.04.1, fully up to date in Sept. 5, 2008.

Comment 24

10 years ago
Confirm bug in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-0.1 Firefox/3.0.1
Linux 2.6.25.16-0.1-default i686
openSUSE 11.0 (i586)

also the gmail tab goes blank if it is foreground
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

This is now WFM (and actually the actual bug itself was fixed in the blocking bug), I'm pretty sure gmail fixed it on their end.
WFM using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.7pre) Gecko/2009012804 GranParadiso/3.0.7pre as well.

Resolving as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: wanted1.9.0.x+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.