All users were logged out of Bugzilla on October 13th, 2018

"Open in Tabs" overwrites existing tabs, "Back" button restores only half

RESOLVED DUPLICATE of bug 175124

Status

()

--
trivial
RESOLVED DUPLICATE of bug 175124
11 years ago
10 years ago

People

(Reporter: andre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Clicking "Open in Tabs" in a bookmarks folder's context menu causes the first bookmark be loaded in the first tab, the second bookmark in the second tab and so on, creating new tabs as needed.
The user can revert the tabs one by one back by switching to the respective tab and clicking "Back".
There are extensions to make the behaviour of "Open in Tabs" configureable but the default should probably be to open a new tab for every bookmark. The correlation between bookmark number and tab number is quite confusing.

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark folder with multiple bookmarks
2. Open at least 2 tabs, load pages in them
3. Right-click the bookmark folder, click "Open in Tabs"
4. Select one of the first tabs and click "Back"
Actual Results:  
See details.

Expected Results:  
See details.

Updated

11 years ago
Component: Bookmarks → Tabbed Browser
QA Contact: bookmarks → tabbed.browser

Comment 1

11 years ago
I get the same results, except my second tab was not loaded over.

I have Firefox 3 beta 5

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 175124
You need to log in before you can comment on or make changes to this bug.