Closed Bug 427689 Opened 14 years ago Closed 14 years ago

Don't switch to a hand cursor on search and search close in the add-ons manager

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3

People

(Reporter: faaborg, Assigned: ehsan.akhgari)

References

Details

Attachments

(1 file, 1 obsolete file)

We should not switch to a hand cursor on search and search close in the add-ons manager, since this is not native behavior on any platform.
Attached patch Patch (v1) (obsolete) — Splinter Review
Drop the cursor:pointer rule.
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #314259 - Flags: review?(dtownsend)
Comment on attachment 314259 [details] [diff] [review]
Patch (v1)

This leaves us with the i-beam cursor when over the buttons which is even worse imho
Attachment #314259 - Flags: review?(dtownsend) → review-
Attached patch Patch (v2)Splinter Review
How about this one?
Attachment #314259 - Attachment is obsolete: true
Attachment #314318 - Flags: review?(dtownsend)
Comment on attachment 314318 [details] [diff] [review]
Patch (v2)

r=me
Attachment #314318 - Flags: review?(dtownsend) → review+
Comment on attachment 314318 [details] [diff] [review]
Patch (v2)

Simple theme-only change to fix a case where our behavior is different to that of user's native platform.
Attachment #314318 - Flags: approval1.9?
Duplicate of this bug: 424519
Attachment #314318 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
mozilla/toolkit/themes/winstripe/mozapps/extensions/extensions.css 	1.55
mozilla/toolkit/themes/gnomestripe/mozapps/extensions/extensions.css 	1.21
mozilla/toolkit/themes/pinstripe/mozapps/extensions/extensions.css 	1.46
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
Duplicate of this bug: 452911
You need to log in before you can comment on or make changes to this bug.