Sign in continues (and fails later) even after receiving 401 errors from server

RESOLVED WORKSFORME

Status

Cloud Services
General
P1
normal
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Chris Vanden Berghe, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: 0.1.29

2008-04-08 17:52:29	Chrome.Window	INFO	Sync window closed
2008-04-08 17:52:44	Service.Main	INFO	Weave Sync Service Initializing
2008-04-08 17:52:44	Service.Main	INFO	Weave scheduler enabled
2008-04-08 17:54:13	Service.DAV	WARN	_makeRequest: authentication failed
2008-04-08 17:54:13	Service.DAV	WARN	_makeRequest: got status 401
2008-04-08 17:54:14	Service.DAV	WARN	_makeRequest: authentication failed
2008-04-08 17:54:14	Service.DAV	WARN	_makeRequest: got status 401
2008-04-08 17:54:14	Service.Main	INFO	Using server URL: https://services.mozilla.com/user/a0da043bab621b90cb7ebaf0db1ad86f1355e056/
2008-04-08 17:54:17	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1
2008-04-08 18:00:05	Chrome.Window	INFO	Sync window closed
2008-04-08 18:00:11	Service.Main	INFO	Weave Sync Service Initializing
2008-04-08 18:00:11	Service.Main	INFO	Weave scheduler enabled
2008-04-08 18:00:18	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1
2008-04-08 18:01:31	Service.Main	INFO	Logging out
2008-04-08 18:01:45	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1
2008-04-08 18:01:49	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1
2008-04-08 18:30:11	Service.Main	INFO	Running scheduled sync
2008-04-08 18:30:16	Async.Generator	ERROR	Exception caught in WeaveLockWrapper: openssl did not run successfully, error code 1

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
error, sign in not successful

Expected Results:  
sign in

Comment 1

10 years ago
I am also getting this error. 

I reset the server data on one computer and was able to login successfully. But cannot login on with another computer. Both computers are running the same version of Firefox and Weave (0.1.29). Here is the Activity log:

2008-05-02 07:18:24	Service.Main	INFO	Weave Sync Service Initializing
2008-05-02 07:18:24	Service.Main	INFO	Weave scheduler enabled
2008-05-02 07:18:25	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1

Here is the Verbose Activity log:

2008-05-02 07:18:24	Service.DAV	DEBUG	GET request for 
2008-05-02 07:18:24	Service.DAV	DEBUG	GET request for meta/version
2008-05-02 07:18:25	Service.DAV	DEBUG	GET request for private/privkey
2008-05-02 07:18:25	Service.Util	DEBUG	Running command: /Users/azander/Library/Application Support/Firefox/Profiles/k6cw6lww.default/extensions/{340c2bbc-ce74-4362-90b5-7c26312808ef}/openssl/unix/exec.sh /Users/azander/Library/Application Support/Firefox/Profiles/k6cw6lww.default/weave/tmp openssl rsa -in key -pubout -out output -passin file:pass
2008-05-02 07:18:25	Async.Generator	ERROR	Exception caught in WeaveLocalLockWrapper: openssl did not run successfully, error code 1
2008-05-02 07:18:25	Async.Generator	DEBUG	Stack trace:
JS frame :: chrome://weave/content/sync.js :: anonymous :: line 356
JS frame :: chrome://weave/content/sync.js :: Sync :: line 71
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/service.js :: WeaveSync_login :: line 412
JS frame :: unknown (async) :: WeaveLocalLockWrapper



JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/util.js :: EL_notify :: line 354
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: anonymous :: line 214
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: AsyncGen__done :: line 237
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: anonymous :: line 103
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/async.js :: AsyncGen_cont :: line 188
JS frame :: file:///Users/azander/Library/Application%20Support/Firefox/Profiles/k6cw6lww.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/service.js :: WeaveSvc__keyCheck :: line 354
JS frame :: unknown (async) :: Crypto_RSAkeydecrypt

Comment 2

10 years ago
Comment #1 looks like a different problem.  It looks like the passphrase given is wrong, so Weave fails to decrypt the private key on the server.

Comment 3

10 years ago
The real problem in comment #0 is not openssl related, it's that Weave is attempting to continue the sign-in after receiving 401 (unauthorized) errors from the server.

Most likely this is because the wrong username or password was given. As opposed to comment #1 which has the correct username & password, but an incorrect passphrase.
Summary: cannot sign in: openssl did not run successfully → Sign in continues (and fails later) even after receiving 401 errors from server

Comment 4

10 years ago
Targeting 0.2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: 0.1 → 0.2

Updated

10 years ago
Blocks: 433899
It would help to have some steps to reproduce for this bug, since I can't do so.  I suspect the recent change to disable scheduled syncs when the user is not logged in has actually fixed this issue, so I'm going to mark this worksforme, but please reopen if you can reproduce (preferably on the latest available build, which is currently 0.1.30) and can provide steps to do so.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.