Support for SMTP Authentication

RESOLVED DUPLICATE of bug 304005

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 304005
11 years ago
11 years ago

People

(Reporter: marcelo.auler, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Bugzilla 3.0

I had problems to make bugzilla works with my mail server, because I needed a SMTP Authentication protocol and bugzilla doesn't support this. Also, when I went editing the code to make this work, I found out that the library utilized ( Email::Send ) wasn't working with auth, I really don't know why, but I think is something related to the protocol it uses. But, I found a library that does work fine ( Net::SMTP ), so if someone plans to implement this function, please save your time and consider changing the library.
Here is a sample of my workaround in Mailer.pm:
                                                                                                                                       // at the init of the code I added to the function another parameter ( to )
sub MessageToMTA {
    my ($msg, $to) = (@_);
...
...
...
 if ($method eq "SMTP") {
        my $smtp= Net::SMTP->new('smtp.yourserver.com',Timeout => 60) or die "servidor nao encontrado";
        $smtp->auth('bugzilla@yourserver','yourpassword') or die "autenticacao falhou";
        $smtp->mail($from);
        $smtp->to($to);
        $smtp->data();
        $smtp->datasend($msg);
        $smtp->dataend();
        $smtp->quit();
    }

I hope this can help you people,
Thanks

Reproducible: Always

Steps to Reproduce:
1. Configure the server to SMTP
2. Sets a server that needs authentication
3. Watch! 
Actual Results:  
The software delayed a lot and the server gave me a Read timeout

Expected Results:  
Email should have been sent.

Comment 1

11 years ago
This is already implemented, see bug 304005.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 304005
You need to log in before you can comment on or make changes to this bug.