Password manager doesn't prompt for the Master Password when using Google Talk

RESOLVED INVALID

Status

()

Toolkit
Password Manager
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Juan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When I'm using Google Talk (1.0.0.104) and I want to go to my mail inbox using Google Talk, it opens my Gmail account with out asking me for the Master Password have configured.

Reproducible: Always

Steps to Reproduce:
1.Open Google Talk
2.Right click/Inbox
Actual Results:  
Goes directly to my inbox

Expected Results:  
I expect that Firefox ask me for the Master Password I had configured, and after entering it, open my inbox.
Sounds like you're already logged into various Google services with cookies, or Google Talk is doing something weird to log you in externally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Is not that way. The thing is that Firefox skips asking for the Master Password when I use that way for going to the inbox.

This happens even if I have not been logged in gmail when startng to use the web. When I use the www.gmail.com page, then Firefox promts for the Master Password. In a fact, the Master Password add may not be dependent of any external apps.

What do you think?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I think Dolske's right, because you say it "goes directly to my inbox." The only thing the password manager knows how to do is fill in your address and password in a form, it doesn't know how to then click the login button, so if Google Talk takes you directly to your inbox, it's because Google is choosing to set a cookie in Firefox to say that you are already logged in based on your Google Talk login. Firefox would ask for your master password if Google was sending it the login form, but it can't know that when Google sends the HTML and script for your inbox, that you don't want them to have sent that, and that you want it to act as though they didn't.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
Ok... You convinced me... Thank you very much for your comments.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.