wrong joining in arabic words, using sukun und kasra with the same character

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Peter Möller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.13) Gecko/20080316 SUSE/2.0.0.13-1.1 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.13) Gecko/20080316 SUSE/2.0.0.13-1.1 Firefox/2.0.0.13

to be honest, i am just starting to learn the writing of arabic words, which also means, that i am not very experienced with joining the chars in html. Anyway, there are bugs with unicode chars.


Reproducible: Always

Steps to Reproduce:
1. Join a "he" (ه) with the char kasra (ِ) and the char sukun (ْ)
2.
3.
Actual Results:  
ff will show a he (looks like a mirrowed p) and above a sukun (small ring), and in between the kasra (horizontal line)

Expected Results:  
the order is correct, but the kasra melts with the sukun and cannot be detected

the url links to a demo site of me, where i selected the word "Muderrisse".
(Reporter)

Comment 1

10 years ago
great job, this bug can be closed after 5 minutes ;-)

verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre)
Gecko/2008040804 Minefield/3.0pre
WORKSFORME per comment 1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.