Compose features disabled after using plain text editor

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: rod.whiteley, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032702 Thunderbird/3.0a1pre

Menus and various other features in the Compose window are disabled after using the plain text editor in builds from 2008-03-27 to the present.

Reproducible: Always

Steps to Reproduce:
1. Write a plain text message. You can send it, discard it, or leave it open.
2. Immediately write an HTML message.
3. In the HTML message, tab to the message body.
Actual Results:  
The Insert and Format menus, and various other things, remain disabled.


Switching focus to another window and back clears the problem.

If the message has a signature, then clicking inside the signature sometimes clears the problem.

Comment 1

11 years ago
Yes, I've been seeing this in recent trunk also.
Just to confirm the regression point:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032602 Thunderbird/3.0a1pre ID:2008032602
Does not show this bug.
 
Magnus, that puts you first in the spotlight :)

Did we miss something (that I'm still not seeing) in bug 373348? The one thing I maybe should have noticed is that we're now including utilityOverlay.js twice, once via baseMenuOverlay.xul and once directly, but that doesn't seem like a very likely cause. Bug 373348 is in the range, too, but that seems even less likely a cause.
Keywords: regression

Comment 3

11 years ago
paste, select, arrows, etc also affected?
If so, I'm seeing the same bug, and html is not a required element.
(my experience is with plaintext)

saving message to draft also resets the problem, temporarily.

Is this really only windows?  ( bug 373348 is OS=ALL)
Severity: normal → major
(Reporter)

Comment 4

11 years ago
You're right. It affects plain text messages too...just more obvious in HTML.

I could not reproduce it on Linux.
Can't reproduce on linux :-/

Bonsai for the regression range:
<http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=ThunderbirdTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-03-26+02%3A00%3A00&maxdate=2008-03-27+02%3A00%3A00&cvsroot=%2Fcvsroot>

Wayne: what did you mean with "paste, select, arrows, etc also affected"? Where?

I don't suppose you see anything in the error console? (And made sure to test in -safe-mode)
It would also be intersting to know if you have this in the seamonkey nightlies as well, or if it's thunderbird only.
(Reporter)

Comment 7

11 years ago
SeaMonkey is OK: Gecko/2008040902 SeaMonkey/2.0a1pre

I see the problem in Thunderbird in safe mode, new profile, clean install, after a reboot.  Nothing in the error console.  Nothing unusual in the console.

Everything in the Edit menu's popup is disabled.  You can type and select with the mouse, but arrow keys do not move the cursor through the text.

A dump in nsDummyHTMLCommand.isCommandEnabled shows that it is never called when the window is having the problem.  That might only be a side-effect, of course.
(Reporter)

Comment 8

11 years ago
I no longer see this problem after the update to: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041103 Thunderbird/3.0a1pre
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.