If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot import root certificate for a new certificate authority

VERIFIED DUPLICATE of bug 387398

Status

Calendar
Preferences
VERIFIED DUPLICATE of bug 387398
10 years ago
9 years ago

People

(Reporter: Andrew Daviel, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13pre) Gecko/20080326 Sunbird/0.8

I cannot see how to import a CA root certificate. Firefox offers this automatically given the correct MIME type, and Thunderbird allows one to import a certificate in Preferences/Advanced, but Sunbird seems to have no mechanism to
do this.

Reproducible: Always

Steps to Reproduce:
1. Connect to calendar using SSL
2. Sunbird displays "unknown certificate authority"
3.



I can use a copy of libnssckbi.so that I compiled with our certificate authority,
but that will not work on Windows and is somewhat complicated to maintain.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387398
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.