Create one linux ref image for both build and unittest

RESOLVED DUPLICATE of bug 425016

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 425016
10 years ago
5 years ago

People

(Reporter: joduinn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

For historical reasons, we have two different sets of ref images and ref platform definitions. One set for Build, the other set for Unittests. 

We want to have only one ref image & ref platform definition, in order to use a shared pool of identical slaves that can be allocated to do *either* Build or Unittest work.

Some differences that will need to be resolved are:
- we *believe* that these have the same toolchain installed on these, but in slightly different locations, with slightly different env.variables.
- different internal networks are used.
- different accounts are used. 

This bug is to track working through all this. 

(A separate bug should track whether we migrate all our existing VMs or just leave existing VMs as is.)

Updated

10 years ago
Priority: -- → P3

Updated

10 years ago
Depends on: 433492
Component: Release Engineering → Release Engineering: Future

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425016

Comment 2

8 years ago
Moving closed Future bugs into Release Engineering in preparation for removing the Future component.
Component: Release Engineering: Future → Release Engineering
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.