Closed Bug 427949 Opened 12 years ago Closed 10 years ago

Quotes are stripped from Invite Attendees list

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 492069

People

(Reporter: richard, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Thunderbird version 2.0.0.12 (20080213) / Lightning 0.8 (build 2008033120)

When I invite an attendee to an event in the format
"Last, First" <first.last@example.com>
this initially works fine. If I later edit the event the double quotes are stripped:
Last, First <first.last@example.com>
When the changed event is saved only the word Last is saved as the first attendee.

Reproducible: Always

Steps to Reproduce:
1. Create a new event
2. Click "Invite Attendees"
3. Add attendee: "Last, First" <first.last@example.com>
4. Click OK
5. Click "Invite Attendees"
6. Click OK
Actual Results:  
Only the word Last is set as the attendee.

Expected Results:  
The attendees E-mail first.last@example.com should be preserved.
Confirming with 0.9rc1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed in nightly build Lightning/1.0pre

This is a real pain as there is no workaround for this. Any attempt to provide only the mail address results in an autocompletion with the First and Last name (as one actually would expect).

As all of my contacts (loaded from an LDAP Directory) are of the form "Firstname Lastname" <First.Last@siemens.com> there is no way to reliably send out meeting invitations :-(.
Duplicate of this bug: 515014
Duplicate of this bug: 514730
OS: Windows XP → All
Hardware: x86 → All
Flags: wanted-calendar1.0?
Using Lightning 0.9 with TB 2.0.0.23 (20090812) I have to add, that if I want to invite a list, only the lists name will be used to send the email notification and thus an error occurs. (Maibox xyz does not exist)

If I save the event anyway, click the list of attendees, and try to "Compose E-mail to all Attendees", I will end up with a new TB window opened and the name of the list is pasted into the "to"-field.
(In reply to comment #5)

See existing Bug 419804.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492069
Flags: wanted-calendar1.0?
You need to log in before you can comment on or make changes to this bug.